PT Logic
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic Studio apps Apogee GiO, Mainstage and Retina MBP problems

Discussion in 'MainStage' started by chrisperry, Jun 21, 2012.

  1. chrisperry

    chrisperry Logician

    I wonder, does anyone else out there use Apogee's GiO and a new Retina MBP? With Mainstage or Logic?

    The colored lights no longer work on my GiO since I've upgraded to a Retina MBP. The switches all perform their functions as programmed, but the indicator lights are just a faint green now -- the same way that they look when you plug it in but don't have Mainstage/Logic running yet.

    Anyway, I've reinstalled everything and it still doesn't work. I've checked and double-checked drivers. I've even spent a 45 minutes with a Apogee tech representative, but no go. I'm beginning to think that there must be some difference between the USB port on my old MBP and the new one.
    I'd be grateful for any help with this problem. I perform live every week and, while I'm glad the switches still work and I can use my pedalboard, I have come to depend on the colors I've programmed into Mainstage to tell me what patches are running, etc.
    Thanks so much!

    Chris Perry
  3. mmm42

    mmm42 Logician

  4. georgelegeriii

    georgelegeriii Logician

    did you try all available USB ports. It's been my experience that usually 1 port is a little less powerful that the other.
  5. chrisperry

    chrisperry Logician

    Yes, I considered that and I tried both USB ports. I even checked the System Report. It says that the ports provide 500 mA and the device requires 350 mA.

    I've made an appointment at the Genius Bar tomorrow. I'm going to bring my GiO in and try it on some of the machines there, hopefully.
  6. chrisperry

    chrisperry Logician

    Went to the Apple Store today and was able to try my GiO on a display model Retina MBP. Same problem there, so it is likely a driver issue--perhaps related to USB 3.

    So it would seem that the ball is in Apogee's court, so to speak...
  7. Doug Zangar

    Doug Zangar Logician

    I recently fired up my MS rig on my laptop and I couldn't get the lights to work on the GiO either. I'm on an older MBP. Hearing of your problems, perhaps it is a driver issue with Lion, as I have neither the Retina Display nor USB 3.

    FYI, I trust you have Lion if it's a new MBP, but don't be shy about sharing system specs......
  8. georgelegeriii

    georgelegeriii Logician

    Hey Doug, did you try the other ports, or maybe adda powered USB hub to test and see if low power is the reason?
  9. Doug Zangar

    Doug Zangar Logician

    Hi George,

    You did prompt me to fire my MBP up and hook up the GiO. I did check that I had the latest driver (I do) and I did test both USB ports. No luck.

    I did not hook up a powered USB hub as I never had to do this in the past. It used to work perfectly plugged into the computer (not even port specific, as far as I can remember) until I installed Lion. Could be coincidence for sure, but I am suspicious........
  10. Doug Zangar

    Doug Zangar Logician


    I contacted Apogee and the reply was spot on to fix my problem.

    In Layout, if you select the screen control stomp button, make sure that in the inspector the "send value to" is set to Port 1 GiO. Mine was set to "nothing".

    My setup worked perfectly in MS 2.1.3 and Snow Leopard. I haven't really used it since I upgraded to Lion and MS 2.2.2. I'm not sure if that setting was changed in the process, or needs to change because of the updated software.

    Anyway, I'm back to pretty colored lights on my GiO.....

Share This Page