Logic Pro 9 Aria as AU for EWI USB instruments


I am using Logic Pro 9.1.6 on an iMac running Lion. I have my Akai EWI USB plugged in and it works with other Logic instruments. The Aria plugin that comes with it is working fine in Garageband to give me access to a set of intruments that already work well with the EWI, doing breath control and all that.

When I create a new track for a software instrument in Logic, and I click on the insert box, I get a list at the bottom of which it says "AU plugins". When I click on that list, I only see Apple plugins. I am supposed to see Akai plugins there. I don't know of any other way to look for it. I am a complete newbie to Logic, just bought it today, though I have been watching a lot of videos about it for a while now.
When I go to Preferences/AudioUnitsManger, I see the EWI USB as first in list, it is listed as an instrument and it says it is valid. I am running it in 32 bit and it also shows up and acts the same way in 64 bit. I don't see anything in the instruments list that gives me a hint that it is there.
Can anyone tell me what I may be doing wrong, or where else to look for it? Thanks.
Are you actually clicking in the instrument slot field on the software instrument channel and not on the inserts-slot? Software instruments are located above the output-field of the channelstrip.

Maybe I'm stating the obvious here, but just to be sure 🙂
Upvote 0
I mentioned it as you wrote in your original post that you clicked on the 'insert box', which is not where the instruments are listed. The instruments are located below that in the I/O box.
Upvote 0
Thanks for bearing with me! i understood that the Aria package that came with the EWI was an audio unit. That is the way it works in garageband, the instruments it brings are not listed with Garageband's instruments. I have to choose an audio unit to run. The AU interface lists the instruments.

From a related post that I read, i inderstood that you get to the audio units available to a track by cllcking on a blank insert slot. When I do that the way I described, i get a pull down list that gets me to all the same audio units I see in Garageband except for the one that I need, which is usually listed along with them.

I am not at my house where the computer is so that I can try it, but I will do so and post again of i can't find it the way you indicate.
Upvote 0
Thanks, Multispace. You were right. When I clicked and held down on the instrument space there was an Akai instruments selection that got me there. I thought I had tried that, but obviously not. Now it works fine.
Upvote 0