Logic Pro 9 Audio disappears after recording region

arthur stead

New Member
Here's a new one: In Logic 9, when I record midi or audio info, I can hear my track back fine. But as soon as I edit that region (by shifting, copying, cutting, etc.) the audio sound disappears!

When I go into the piano roll editor, or sample editor, I can hear what's there, and can fool around with the notes/samples). But back in the Arrange window, I can't hear anything! The only way to regain audio, is to quit Logic and boot it up again. Then the sound is back.

Any ideas or suggestions would be greatly appreciated.

arthur stead

New Member
Hi George,

No, nothing to do with being in or out of record. Spoke to Doug Zanger, and he, too, has never heard of this. I did discover that Logic is functioning properly when I open a new project. So I may have to transfer all my relevant audio and midi tracks from this project, to the Arrange window in a new (empty) project.

Any tips on how to accomplish that easily?

arthur stead

New Member
Could you give me a few more details about the steps to take in order to import tracks and audio files? I've gone to the main menu file and selected import. Then from the media browser, I selected the original project, and imported everything. They all show up in the new project's media file (including audio files, marker track, signature, etc.) But then I'm stuck. Nothing appears in the actual Arrange window tracks. Please advise. Thanks!
Not sur why it's not working there. You did choose the content as well as the plug-ins right? It works perfect here. Try this:

Grab the audio files from the audio bin, drop them into new tracks, and then move to original record position. Once you can "see" the audio, you will need to move them to the correct track.

Are you SURE you haven't changed a key command or something between your new projects and the old one? Are you sure you haven't made a dual "delete but keep audio" somehow?

I can't help bust suspect something like this rather than Logic, especially since no one else seems to suffer from the same issue. In my limited experience, it is almost always the user (including myself over the years) who has made the issue happen, and it is almost always something very nondescript and entirely un-obvious that is the actual cause, and always the users rather than the app.

No finger pointing, just a hunch...

Doug Zangar


Sounds like no more luck on solving this?

Did you try this using the system audio, not the Ensemble and was the behavior the same?

Is this happening on other files, or just this one?

Import normally works, I've rescued projects before using it. Have you tried it on another project to see if works then? FYI, your steps sound correct.

You could also try having project in question open, open a new project and copy/paste (or drag/drop) region(s) and see how they behave in the new project.

Sounds like a serious corrupt project or perhaps Logic preferences - or the program itself is corrupt if it happens in multiple projects. That said, George could be right as well and you inadvertently tweaked something. We've all done that....

You could post the file here (minus audio) or send me a copy and I'll look at it.

arthur stead

New Member
Hi Guys,

First, thanks very much for your tips and suggestions. Second, I certainly could have accidentally triggered an obscure key command - although I was not aware of doing so. And third ... my audio signal is back!

Strangely, when this problem started, the first thing I tried was to see if there were any new Apple or Logic or Apogee updates. But my computer told me everything was up to date. Then, today, I received a notice to download a new update. And voila! No more audio problems! My original project is intact and OK to continue working on.

So, no explanation for why this happened, but I am back in business.

Thanks again for your help - much appreciated!