Logic Pro 9 Audio stops while practising

peterlemer

Logician
I have a simple song set up with an 8-bar cycle with MIDI clicks occupying the 1st 4 bars.
I play Ivory set to minimum velocity 67 and get on with my finger exercises.

Every so often the sound simply stops dead, including the click, although the song continues its cycle.

I have Logic and Fireface software up to date.

Any ideas why the sound drops out?

pete
 
What is your buffer set too? Ivory is a major ram and CPU/Drive power hungry plug-in. Using a small buffer (anything less than 256) can cause the problems you are experiencing.

Try a larger audio I/O buffer (256) and less voices on the Ivory setup (say 32 rather than the default, which is 64 or 128, I can't be sure). That should help.

Another thing: where are you streaming your samples from? If you are using a FW drive, that may also be an issue. The internal data busses on the Mac Pro's are WAY better than any FW drive will ever be, by about 4 times the streaming speed.

So, there are a few things to try.
 

Markdvc

Administrator
Staff member
George, I think has said just about everything, I would like to add one suggestion - how about swapping ivory for an EXS 24 piano for the purposes of testing/comparing? If this doesn't happen with the EXS 24, you may be a step closer to isolating the problem.

kind regards

Mark
 

peterlemer

Logician
Hi George - buffer already set to 256.

Ivory voices = 24

Streaming from internal Velociraptor.

Would Ivory overload ( if any there be) stop Klopfgeist speaking while leaving the song running?
 

peterlemer

Logician
Hi Mark, the problem occurs infrequently - which means lots of practise with EXS 24.

Does this forum supply Ivory withdrawal tablets?

pete
 
OK, have you tried these ideas: Replace your FW cable to your audio interface? Opened Activity monitor and tried to get an idea of where your CPU levels are when playing? Tried different I/O buffer sizes? Since you use a FW interface, I'd really have to start with that.

I was also thinking: have you tried to listen to sound straight from your Mac's audio out (say with headphones) and see if you get the drop out there? That would be a good way to confirm the FW being an issue or not.
 

peterlemer

Logician
george et al: the dropout occurred outside Logic too! This points directly at Fireface or cable. As it happens, RME have released an update for Fireface which I have installed today. Unfortunately they haven't published a features list for the latest version so I'll just have to wait and see if this release addresses the drop out problem

cheers

pete
 
Top