Logic Pro Avoiding Loop Transposition

dougjammer

Logician
I am using loops from Bass on Demand (same company as Drums on Demand) and I do not want them to transpose automatically when I insert them. For example, the key signature is D major. When I add a loop that is in G, Logic transposes it to D. The transpose box in the Region parameters is not checked. Can someone tell me how I can turn off the automatic transpose feature? It does adjust the rhythm automatically which is great and I do not want to stop that feature.
Thanks!
 

dougjammer

Logician
Further info: I am not able to see the "No Transpose checkbox" in the Track inspector. Would this be because I am not using authentic Apple Loops?

Figure. Track Parameter box with the No Transpose checkbox selected.
 
Upvote 0

CSeye

Logician
If you've downloaded the Apple loops format vs. WAV, then what you're describing is the expected behavior.
The track inspector No Transpose option is typically used for drums to prevent them from being transposed when other song tracks are being transposed.

There are two options
1. Use the Region or Track inspector transpose field to non-destructively adjust the loop back to the original key.
2. In a separate project with the project key set the same as the loop's original key, right-click the loop(s)>Convert>Convert to New Audio File(s).
 
Upvote 0

dougjammer

Logician
Thanks CSeye! I figured out a way. It was a bit tedious, but it worked. I didn't figure out your option 1 (which I'll try next time I am in this situation), but I did something similar to option 2. I created a few new projects and set the tempo the keys to what I wanted the loop to become. I bounced each loop into the Audio Files folder and inserted them. Since they were no longer loops they worked. Thanks for the help!
 
Upvote 0
Top