Logic Pro 8 Blue Loops - Key Chain Issue

#1
Sorry if I am missing something obvious, but I am stumped.

I know how to listen to blue audio loops in the loop browser in different keys and I know how to set the project key in the global track list. Where I run into an issue is when I change keys in the global track list, the loop doesn't change key. I have tried this three different ways. Assume measure 1 is in E and measure 5 is in A.

Various Methods:
1. Where the loop is looped from measure one on. This makes sense that it wouldn't change key
2. Where the loop is in measure 1 and then copied to measure 5. The loop stays in the key of E even though the global track key says A.
3. Where I have pulled the loop over from the browser into measure one and also pulled it over from the loop browser into measure 5. It says in E and doesn't change to A.

Thanks for your advice.
LMP
 
#3
Doug,
First let me thank you for the outstanding training DVD's you have done for Logic. Although I am still working my way thru them, you have expanded my thinking many times.
Re: my issue above, I have still not solved. As noted, I have been working with the Global track parameters. This works fine on midi loops (as one would expect). However, my understanding of Apple Audio loops is that it should work this way as well. This is the first volume of the Apple Pro Training book* (yep, I know, you did write this). So, if you or someone else could shed some light on why it doesn't, I would appreciate. it.
I know you can individually transpose a region in the inspector, I was looking for a faster way.

* I do not mean to dis the Apple Pro Training book, which I think is excellent.

Thank you,
LMP
 
#4
LMP,

Thanks for kind words on training DVDs. Glad they could be of help to you.

To clarify (and I think you just did a typo) David Nahmani wrote the Logic 8 level one training manual. It's a very good book, however, you may find an inconsistency or two as it was written for version 8.0.

Near as I can figure on this, you need to put a node on the transposition track (value of zero) at the same point of your key signature change in order to get the signature track to modulate the loops.... :eeek:

Try that and see if it doesn't work for you. It works here. If so, we're both a little more of an expert on loops :D
 
#5
Doug,

Again thanks for your response. You are correct on all points.

- Yes, I made a goofy typo. I do realize that David Nahmani wrote the excellent Apple Pro Training Logic Pro 8 and Logic Express 8 book. I should proof my typing.

- Re: your response to my transposition of audio loops question, yes it does work. I am scratching my head to understand why it works that way, but it does. It seemed to work best when I:
o A. Input the Key Changes into the Signature Global Track
o B. Created zero nodes in the Transposition Global Track at each key change (as you recommended)
o C. Pulled the loops over
- Interestingly enough, after doing this, the midi loops transposed, as is desired, as well.

If anyone else has any more insight into this, please let me know. There is no LUG in this area so I doubly appreciate the support from this forum.

LMP
 
#6
Try this:
In the Arrange window, go to the local [View] menu and select [Configure Global Tracks.
Make sure that [Signature] and [Chord] and [Transposition] are ALL enabled. Open them up using the arrows at left.

Drag a blue loop onto an audio track.

Set your initial Signature to be the same as the loop key (eg A)
Double-click on the Transposition channel to create a node at bar 3. Drag this down to -2. You should see that the Chord track now says "G" at the same point. You should get an alert message that warns you about Apple Loops etc.

The loops should now follow any Transposition nodes you create.

Check out the Logic 8 manual, Chapter 32 page 661 for all the info....
 
#7
Colin,

Thanks, All is clear now.

I had been using the Signature Global Track rather than the Chord Global Track. Once I played around with the Chord Track, all fell into place.

Thanks again to you and to Doug.

LMP
 
Top