Logic Pro 9 BPM problems

#1
Hi people,

I have encountered an odd behavior (or is it normal?).

A guy sent me about 30 audio tracks to rearrange and mix. He tells me the bpm is 90.

I opened a new project, imported the tracks, played them and all was fine.

However, when I set the bpm to the correct 90 bpm, everything is completely off. I don't recall this type of behavior with audio tracks...

Any ideas, or is it normal?

Thanks. ;)
 

Eli

Logician
#3
Check that your project sample rate matches the sample rate of the audio files. This could also explain the discrepancy.
 

Orren Merton

Logic Samurai / Administrator
Staff member
#4
However, when I set the bpm to the correct 90 bpm, everything is completely off. I don't recall this type of behavior with audio tracks...
Were the tracks recorded in Logic 8 or above? It sounds to me like one of two things may have happened:

1) The tracks had tempo information other than 90BPM, so when you changed the tempo, the tracks were time shifted

2) The tracks had no tempo information in them, and when you saved the song, it saved the tempo information of the original project tempo.

If either of these cases happened, you'll want to change the tempo information in the tracks themselves to be 90BPM.

HTH,
Orren
 
#7
However, when I set the bpm to the correct 90 bpm, everything is completely off. I don't recall this type of behavior with audio tracks...
Were the tracks recorded in Logic 8 or above? It sounds to me like one of two things may have happened:

1) The tracks had tempo information other than 90BPM, so when you changed the tempo, the tracks were time shifted

2) The tracks had no tempo information in them, and when you saved the song, it saved the tempo information of the original project tempo.

If either of these cases happened, you'll want to change the tempo information in the tracks themselves to be 90BPM.

HTH,
Orren
The person recorded the tracks in PTLE.

I'll try to change the tempo info in the tracks themselves. I'm not sure how to do it. I'll search, and keep you posted.:)
 
#11
OK - version info helps. Please consider creating a signature with this.

One thing not mentioned - is it possible you have applied flex time to these files?

I can't seem to find what the procedure is...
To remove tempo information go to Main menu>Options>Tempo>Remove tempo information from audio file.
 
#12
OK - version info helps. Please consider creating a signature with this.

One thing not mentioned - is it possible you have applied flex time to these files?

I can't seem to find what the procedure is...
To remove tempo information go to Main menu>Options>Tempo>Remove tempo information from audio file.
I have not applied any flex-time to the files.

Removing tempo info is not helping any... :errr:

I don't know what to do..

This is a very odd behavior...

I need help...
 
#13
Strange stuff. Audio files don't normally to adjust to tempo.

Have you tried creating a new project, setting the tempo at 90 BPM and then importing tracks? You want to use tracks that were not saved by the previous attempt(s) in Logic - make sure you have the original files (Logic should have copied and saved a separate set by its default preferences - they will be in the project folder)

You might consider uploading a small piece of one of the audio files to be examined. Also, what glyph shows up in the bin next to the file - the link below is dated but has most of the glyphs:

http://support.apple.com/kb/TA25098
 
Top