Logic Pro (X) BUG: Click holding region MOVES it.

Kim Olesen

Logician
I SWEAR i am NOT moving the mouse. ONLY click-hold. But the region moves. Does not happen in small sessions. But in large sessions it happens often. It's an editing NIGHTMARE.
 
Last edited by a moderator:
I've read about this elsewhere and have experienced it myself. I swear it's also happened to me in the Piano Roll Editor. My workaround has been to make selections by click -dragging.
 
Upvote 0
Has happened to me also especially in piano roll editor. Sometimes in piano roll merely clicking on an event will somehow 'stick' it to the mouse pointer causing you to move it accidentally when you move the mouse. I just click undo.
 
Upvote 0
This "mouse-catching" seems to happen all over the GUI. I hate it especially with automation. You either have to place the mouse pixel accurate or read the current value before you click, because the mouse pointer will instantly catch and pull the line.

I wonder if this has to do with all those mouse-over actions we got.

Btw, who of you has ordered the flickering slot images in the mixer, for one-hand clicking on effects and sends? - Sunday morning at sunrise, the alley behind the church. You choose the weapons.
 
Upvote 0
I'm having a very hard time just dragging regions around in general and having them go to the correct spot. I was option dragging a chorus vocal yesterday to the second chorus and had bars selected and relative value so it would line up correctly but it just wouldn't. I never had this issue with L9.


Sent from my iPad using Tapatalk
 
Upvote 0
Daveyboy,

Have you made sure to turn off alignment guides?
 

Attachments

  • Alignment Guides.png
    Alignment Guides.png
    34.9 KB · Views: 188
Upvote 0
Hi Kim,
How long have you been having this problem? I've had it since the beginning of Logic X. It often has nothing to do with Alignment guides. The only workaround is to zoom in close enough. Apple doesn't understand what is happening and can't help me. I am considering a clean install, because this thing could really f*** up a whole arrangement. I sinceryl it's worth the time and trouble to do a clean install. I have a hunge that is has to do with Logic 9 and X coexsisting and sharing settings. Do you have Logic 9 installed?
 
Upvote 0
I have Logic 9. In versions prior to 10.0.5 turning alignment guides got rid of most of it though it would sometimes happen. In 10.0.5 it has gone completely with alignment guides off. Don't know how it is with them on because i dare not switch them back on in case the problem should come back.
 
Upvote 0
I understand. I will test it for you and keep you posted. I love working in X, and I am in the process of moving current projects over from 9 to 10, so I don't really have a choice.
 
Upvote 0
Back
Top