Logic Pro 9 cannot see note velocity data in piano roll

edurbrow

Logician
A lot of the time in the piano roll, I cannot see the note velocity data even though the box is checked to display. Sometimes they are there and sometimes not. I cannot discover the rhyme or reason or how to turn them on when they refuse to show.
 

Eli

Logician
Make sure to click that little icon with the horizontal velocity lines display at the bottom left of the Piano Roll window. They toggle the display of controller information. You can see it in this screen shot directly above (and slightly left) the mixer tab at the bottom of the window.
 

Attachments

  • Piano Roll Velocities.jpg
    Piano Roll Velocities.jpg
    29.2 KB · Views: 275
Upvote 0

edurbrow

Logician
Make sure to click that little icon with the horizontal velocity lines display at the bottom left of the Piano Roll window.

Of course. :) I should have taken a screen shot. My window looked just like yours except no data in the lower half. Now all are showing the velocities. Like I said, it happens sometimes. So, can you think of a case where you would have the bottom half visible, note velocity checked, and you don't see data? I'll take a screen shot next time it happens.
Thanks,
 
Upvote 0

Eli

Logician
Hmm, I can't think what circumstances that might happen in. I think maybe sometimes link and catch mode don't work as expected when the transport is stopped and different tracks and regions are being selected. So, is it possible that when this happens, you are not viewing the contents of the regions you think you are viewing?
 
Upvote 0
Hmm, I can't think what circumstances that might happen in. I think maybe sometimes link and catch mode don't work as expected when the transport is stopped and different tracks and regions are being selected. So, is it possible that when this happens, you are not viewing the contents of the regions you think you are viewing?

I can confirm that the Link and catch modes are often not working as expected. One of the reasons is that Logic has a number of submenus, and each requires being set up a certain way for things to work as expected.
 
Upvote 0

Tangra

Logician
I cannot see the note velocity data even though the box is checked to display.

Try next...
In the Piano Roll go to View->Hyper Draw->Channels and check "Any" which will show the velocities of all note events in case if the region consists note events using different midi channels.

A.G
 
Upvote 0

edurbrow

Logician
In the Piano Roll go to View->Hyper Draw->Channels and check "Any"

Okay, 'Any' midi channel is checked, note velocity is checked, but no velocity data are visible. I think this has something to do with switching from viewing automation. And, btw, automation is now off. Once, earlier, I clicked on the track area on the left, in the Arrange Window, even though it was highlighted, and note data appeared in my Piano Roll Window.

Also, is there a way of knowing which track is showing in the Piano Roll Window? I mean the one that comes up from cmd 6. I have two tracks here A filter ensemble and G filter ensemble. Those are the names I typed into the Name area. However in the Piano Roll they both say :filter ensemble.
 

Attachments

  • Picture 27.png
    Picture 27.png
    47.8 KB · Views: 71
Upvote 0

Tangra

Logician
I had a look at your image attachment and found out that you are doing wrong.
The Hyper Draw display in the Piano Roll is set to show CC#2.

Click the "Arrow" button to the left of the Hyper Draw and choose "Note Velocity" in the flip menu to show the velocity!

A.G
 
Upvote 0

edurbrow

Logician
I cannot see the note velocity data even though the box is checked to display.

Try next...
In the Piano Roll go to View->Hyper Draw->Channels and check "Any" which will show the velocities of all note events in case if the region consists note events using different midi channels.

A.G
Hmm. Did that. Selecting a note or many notes makes no difference.
 

Attachments

  • Picture 28.jpg
    Picture 28.jpg
    38.5 KB · Views: 63
Upvote 0

edurbrow

Logician
I had a look at your image attachment and found out that you are doing wrong.
The Hyper Draw display in the Piano Roll is set to show CC#2.

Ah so that is what the little orange 2 is. Actually when I took that shot, velocities were selected in the menu. See my last post for another shot with no 2 and still no data. Any idea there?
Thanks so much,
 
Upvote 0

Tangra

Logician
edurbrow; said:
See my last post for another shot with no 2 and still no data. Any idea there?

Could you provide that Logic song so we can try. Save as a new version and disable "Assets" in the Save As dialog. You can delete the other regions instruments etc, just leave the region in question. By the way which Logic version do you use ?

A.G
 
Upvote 0

Cunfuzed

New Member
In my own case, I noticed that if you have two or more regions on the same track that aren't glued together the note velocities for one (or more) of those regions may not display. Once glued together all note velocities on the track display.
 
Upvote 0
Top