Logic Pro 8 Changing Sample Rate and Auto-Adjusting Automation Events

#1
Hello. I finished mixing an entire piece at 44.1k before realizeing the audio was recorded at 48k (it's abstract electronic music, so it wasn't obvious to me until one of the musicians pointed it out).

There's a ton of automation.

When I flip the project sample rate from 44.1k to 48k, the automation doesn't adjust -- So, the audio tracks get shorter, but all the automation events stay where they are.

Is there an easy way to get the automation to auto-adjust so the events shift with the audio tracks?

Thanks for any help.
 
#2
My solution --

I measured the the audio tracks in terms of Bars/Beats before changing the project sample rate. Changed the sample rate. Then changed the tempo until the track-lengths matched the original Bar/Beat lengths.

I could do that because it's an all-audio mix and the tune is free-form. I couldn't have used this solution If I needed to maintain the tempo.
 
#3
This might work:

-Select All

-Arrange -> Track -> Track Automation -> Move All Track Automation to Region

Then change sample rates - events within the region. (?)
 
#4
I'll have to try that next time, thanks.

But, the new region is now smaller than the original region because of the sample rate change. The real issue is if that operation will scale the automation events. e.g., the original region's bar lenght at 44.1 was approx 150, and when I set the project to 48k, the bar length changed to somewhere in 140's.
 
#5
This procedure works when you want to make tempo changes and have to SMPTE-lock the regions _and_ the automation. In your case it's the opposite - you want the automation to move/scale with the regions, which I think it will if it's embedded and not SMPTE-locked...
 
#6
I see your point.

I'll try it out, thanks.

This procedure works when you want to make tempo changes and have to SMPTE-lock the regions _and_ the automation. In your case it's the opposite - you want the automation to move/scale with the regions, which I think it will if it's embedded and not SMPTE-locked...
 
#7
For future reference, the menu path should be:

Options (not Track) > Track Automation > Move All Track Automation Data to Region

(That's where it is in v8.0, don't know about later versions)

Still need to try it out...

Thanks.



This might work:

-Select All

-Arrange -> Track -> Track Automation -> Move All Track Automation to Region

Then change sample rates - events within the region. (?)
 
Top