Chords won't transpose


Having generated a global chord track from MIDI events, I then used ' Insert chords from Global tracks' function.

In some staves it simply didn't work - I'd love to know why.

I finally got a region'sworth of chords, and then copied them to a MIDI region - but when I transposed the region , the chords didn't transpose.

What is going on, please? When I enter chords by hand, they transpose according to the style transposition. the chords derived from the global track appear identical in all respects ( event list; select similar objects etc) other than they're coloured blue. What is the point of deriving chords from the global track if they won't transpose properly?


Really - it's screwed up. To my recollection this has never worked right. It will only create grief. It's possible it's fixed in 9.0.1, though I'd be surprised. You don't say what version you're using - if you were in 9.0 you wouldn't even get the right chords to show up - are you in 8.x?

You may have done everything right and it will still screw up. There are various threads over at Logic Pro Help and perhaps some here if you want some boring reading. I've checked this out thoroughly through version 9.0 and it has always been buggy in some manner.
> Peter - DON"T USE THIS FUNCTION!!!!!!!!

don't beat about the bush, Doug! ;-)

no... it's good to hear you - it's not a function I've ever used and thought I should check it out - it does seem rather convenient.

No need to refer me to earlier threads. I shall revert to my regular techniques.

Has this been reported to Apple?


Well, I did want to make myself clear.....

I've been whining and sniveling about this function since it showed up in version 7. I actually think it worked better in some ways back then. I'm not sure I ever fired anything off to Apple, but they have to know about. I'm sure someone is reading the various forums (they could be watching me right now :eeek:)

And yes, the idea is great. Could be a time saver if it worked.