Logic Pro 9 Click accents are wrong

thesoberwalker

New Member
Hi everyone,

I'm using Logic Pro 9 and I'm working on some midi piano recording. I have the time signature in my session set to 6/8 and I'm using the click. But for some reason the click is accented as if the sig. was 3/8. So it sounds like CLICK, click, click, CLICK, click, click. I tried to surf the web to find an answer but came up empty handed. Does anyone know how to remedy this? It should go CLICK, 5 clicks, then repeat. The clicks ARE 8th notes, so the program isn't spitting out 3/4, but why the mid-measure accent? Does anyone know how to remedy this? And yes, I realize that rhythmically these signatures are basically the same but I feel like I should be able to hear the accent click only on the first beat of each measure in this piece.
 

Doug Zangar

Logician
AFAIK, you'll have to create your own one bar MIDI click and loop it for that type of accented metronome. Not one of Logic's strong suits......
 

Colin Shapiro

Logician
6/8 time is generally accepted as a compound time, 2 sets of 3 divisions. Maybe the creators of Logic thought that each division should be marked with a louder click, as you're hearing.
Having said that, when I just tried a click (Klopfgeist) in 6/8, I get *CLICK* click click CLICK click click - where the one in the middle of the bar is in fact slightly softer.

Have you checked your project settings?
Go to File/Project Settings/Metronome
You can set velocities for the Bar clicks and beat clicks as well the note pitch.

Mine is set like this:
 

Doug Zangar

Logician
Colin, you inspired me to play around with the metronome settings - something I never do.....


Anyway, if one is in 6/8 time and sets the Transport bar division to 1/8th notes and has the the Bar and Division boxes checked (Bar is unchecked) the metronome click originally requested is produced - CLICK, click, click, click, click, click.
 

Colin Shapiro

Logician
Anyway, if one is in 6/8 time and sets the Transport bar division to 1/8th notes and has the the Bar and Division boxes checked (Bar is unchecked) the metronome click originally requested is produced - CLICK, click, click, click, click, click.
Doug, I'm sure you mean Beat is unchecked (not Bar)....yes, that does work. Setting the Transport division to 8ths can be confusing though, if you're used to the tick value for 16ths in the Event list.
 

Doug Zangar

Logician
Yes, I did mean Beat is unchecked. And agreed changing the division has it "side effects". But, one could record and then reset division. Just wanted to play around with the metronome settings and see what might be possible.
 

CSeye

Logician
After checking out Doug's tip for a 6/8 click, I noticed that increasing the velocity and maybe changing the note pitch helps with the clarity of the pattern.

Also adding to Doug's initial recommendation of creating a one bar looped MIDI click track, the OP could Hide that track as it's not otherwise relevant to the project. Taking this a step further, clicks for various time signatures could be created, then placed inside a folder track, all muted accept for the one currently needed, with the track Hidden in a custom template.
 
Top