Logic Pro 9 Clicks'n'pops, hardware inserts only, analog outputs only (?!?)

Hey, guys. This is the most pernicious bug I've ever chased down and I have to say, one of the most maddening. It took about three days of troubleshooting to get this far; prior to this I was blaming it on mLAN and actually bought $400 worth of gear to counter it.

The issue is this:

When I set an insert in a channel or bus in Logic 9, I get random, sporadic "pops" (1 sample triggers, I think) on any open insert.

- but only on the left channel

- but only if the insert is an analog signal pass - going TDIF bypasses the issue

SYSTEM (bear with me)

Computer Model: 2x 3.2GHz Quad-core Xeon

Amount of RAM: 20 GB 800 MHz DDR2 FB-DIMM

Audio Hardware: 2x MOTU 2408 Mk II via PCIe-424 card, clocked at 48kHz via Lucid Genx6 master clock (into 2408 #1). System is heavily reliant on TDIF, with monitoring via Tascam DSM7.1 (clocked via wclock). Other gear includes a Kurzweil K2500xs and Kyma Capybara 320(wclock) via IF-AE8 (clocked via TDIF), Onyx 800R (wclock) and Kurzweil KSP-8 (wclock), AES out to IF-AE8HR (TDIF) to 2408 #2. The analog outputs on 2408 #1 are used to drive a pair of Dorrough 80As. The analog outputs on 2408 #2 are used for the FX Inserts in question.

the exact OS version in use: 10.6.7.

the exact Logic Version in use: 9.1.1. Although thanks to this forum I discovered that keeping Logic in an Applications folder called "audio" makes it not update, so I moved it and updated it and the problem didn't go away.

other audio software such as Audio Units or software: Well there's a bunch in there, obviously. However, I've narrowed this problem down to just Logic and an instance of ES1 to test it with and it's still there. I was initially coming into the KSP-8 via mLAN and thought my problem was the Aggregate Device Editor, so I ripped out the mLAN card and replaced it with an AES card, and then came AES out of the KSP-8 and into the IF-AE8HR (purpose-bought) and out of that into the TDIF on 2408 #2. So I spent about $450 trying to fix this problem and it didn't go away, much to my consternation.

* * *

So basically the problem is this. I've got an Eventide H3000, an Ensoniq DP/Pro and a Sony V77 that I like to use. I used to come out a channel and back in a channel to loop through these but when I upgraded to Logic 8 I started using them as inserts, which worked dandy. No pops, no nothing. Then I upgraded my system from Logic 8 on a dual 2.5GHz G5 to Logic 9 on the 8-core 3.2GHz Mac Pro I'm running now. I bought a KSP-8 about the same time.

I used to hit the Eventide, the Ensoniq and the Sony analog with no problems. I hit the Kyma AES via TDIF with no problems. I hit the K2500XS via a KDFX via TDIF no problems. But as soon as I upgraded to the Mac Pro, ver 9 and the KSP-8, I discovered these pops.

Here's the stupid thing. I *only* get them on the analog outputs to the Eventide, the Sony and the DP/Pro. I do *not* get them to the Kyma, I do not get them to the KSP-8. I *did* have to upgrade from a PCIx-424 to a PCIe-424 when I did that; however, I've done a fair amount of chasing so I don't know if it's the MOTU card or not:

- It's the left channel only, always (shows up on the channels with the inserts)

- The more open analog inserts, the more pops and clicks each channel gets

- It seems to simultaneously fire 1-2, 1-4, 2-4, 1-2-3-4, 1-2-4, 1, 3, but never just 2, never just 4

- I've replaced the firewire cable to no avail

- I've changed the port I'm using on the 424 card to no avail


- Changing from 32 bit to 64 bit and back (no change in either mode)

- Changing I/O buffer size (no effect)

- Changing process buffer range (no effect)

- Changing Re/Wire behavior (no effect)

- Changing plug-in latency (never goes away, although compensation off seems to speed up the hits)

- Changing to low-latency mode (no permanent change, although setting it to low latency paused the hits for 15 seconds?)

- Turning off 24 bit recording (no effect)

- Turning off software monitoring (no effect)

I'm not getting any of this in Cuemix Console, MOTU's native app for patching and repatching within the 424 card. And I'm pretty well at my wit's end.

I'd love any input or advice.


Hi, I had some similar problems but was lucky to be able to trash the settings in the OSXAudio/MIDI setup, that was causing all settings to go bad and since my peripheral equipment will work without the Audio/MIDI I am working again. If you are not using the setup this won't help, sorry if that's the case.
Upvote 0


The only time I run through outboard gear is for mastering. And I too have noticed the pop. It doesn't always happen, but it does happen a lot. I usually have to edit it out after printing the track. I have been unable to determine a solution, though I haven't really looked into it. It does this on both my computers. The macbook pro and the tower, regardless of OS and Logic version. (10.6.x and 9.x respectively)
Upvote 0
Hi, I had some similar problems but was lucky to be able to trash the settings in the OSXAudio/MIDI setup, that was causing all settings to go bad and since my peripheral equipment will work without the Audio/MIDI I am working again. If you are not using the setup this won't help, sorry if that's the case.

David - could you please elaborate on "trash the settings?" Do you mean a preferences file? If so, which one?

One of my constant bugbears is OS X *insists* on running at 44.1 by default, which means when I fire up the computer I have to load a settings file in the PCI 424 editor. It's gotten pretty streamlined - I hit apple-space, then type "48k" and then hit enter and my settings file loads - but it *is* something I have to load every time I turn on the computer.

I should have mentioned that attempting to reload that file *does not* make the pops go away.

I *really* wish there were some way to go in and do a "registry hack" like in the Windows days and say "Pay attention, computer: you're never, ever, ever going to operate at 44.1kHz again."
Upvote 0
Are you connecting your wordclock devices with "T" BNC connectors (i.e., a "ring", or "loop")? I have a 424 connected to 2408 Mk3, 2408 Mk2, 1224 and 308, but my wordclock master is an Aardvark 2 connected to a wordclock distribution amp. All my wordclock cables are direct runs from the distribution amp to each slave (cables between 1 and 6 feet max). When I change the master clock (to 44.1 or 48 or whatever), all the MOTU interfaces slave to it automatically. There is also a second computer with an RME HDSP9652 card that will sense the wordclock change from the Aardvark.

It's not the same setup, and it sounds like yours is even more complex. But I am not getting any clicks or pops.
Upvote 0
>Are you connecting your wordclock devices with "T" BNC connectors (i.e., a "ring", or "loop")?

I wish it were that simple. No, the GenX6 has 6 outputs, and I'm direct out of each output into each piece of gear. The only exception is the IF-AE8HR, which has a dedicated loop-through (going to the KSP-8). No T connectors anywhere.

I did notice today that if I reload my PCI-424 preset in the midst of doing stuff, the "pops" go away for a few minutes. Which leads me to believe it's either an OS X problem or a Logic problem. At which point, what do you do?
Upvote 0


Slave2thelight-I tried to post this a few minutes ago but kept being told my "something" was too short-must contain 5 cyphers, I stopped trying after 10 attempts. I did put the pref file for com.apple.audiomidisetup in the trash and then I think Logic,no,the OS makes a new one that I left blank, in other words I stopped the Audio/MIDI from doing anything because my simple set up works without it.
Upvote 0
So the KSP-8 goes out AES to an interface that converts it to TDIF, and that TDIF signal goes into the second 2408? Either the MOTU 1224, 1296, HD192 or 308 have AES ports that would let you eliminate some of your digital signal conversions.
Upvote 0
I'll try trashing com.apple.audiomidisetup to see what happens. I've noticed it's better than it was in 10.5; used to be I'd have to "remind" OS X that it was externally clocked to 48khz but now once it wakes up and I tell it once, it's usually pretty good...

Juan - On the first 2408 I'm using 3 TDIF banks. If I didn't go TDIF I'd need 4 pairs of AES and 2 TDIF banks. On the 2nd 2408 I'm using 1 TDIF bank, one ADAT bank and one Analog bank. If I didn't go TDIF I'd need 8 analog, 4 prs of AES and one pair of ADAT or TDIF.
Upvote 0
"Sounds like a clocking issue to me?" Based on what?

The 308 would do exactly nothing for me. I have no reason to use SPDIF for anything and I need 8 ports of AES minimum. And it still doesn't cover the ADAT side of things.
Upvote 0
Yeah - the clicks'n'pops associated with Kurzweil keyboards is something completely different. That's an issue that took me forever to find, too - it comes down to needing the latest firmware chips inside the keyboard. I've also noticed that a voltage instability will push the K2500 out of sync, but that will revert.

The issue I'm facing with my analog inputs is something completely different. The KSP-8 never pops, and it'll happen whether or not the K2500XS is even *on* let alone on those channels (I'm hitting the K2500XS digitally, via a DMTi).
Upvote 0
Definitely a clocking problem.


It was not a "clocking problem" in Logic 8 and 10.5 with the exact same physical setup.

It has not been a "clocking problem" with anything digital that is actually *clocked.*

It is only a "clocking problem" on a select bank of analog outputs and inputs, on an IO that does not have a "clocking problem" on anything digital.

If it's a "clocking problem" what "clocking problem" is it? 'cuz every piece of gear that has a port for it is getting a straight, dedicated piece of RG-6 straight from a Lucid master clock, and every piece that doesn't gets that said-same Lucid master clock passed down whatever port it will take. Every piece of gear in *need* of clock is rock solid... the only outputs that are generating clicks and pops are *analog.*
Upvote 0