Convert old Logic files

pianojoe

New Member
Current versions of Logic Studio can't access very old Logic files (<V.5). You'll have to open them in Logic Pro 5-7, and re-save them. Fun fact: Logic Pro 7 doesn't run on current systems.

I've set up an old Mac (Power-PC, OSX 10.3.9), complete with a Logic dongle, to be able to access my old stuff.

I assume that I'm not the only one facing this problem, so I decided to offer Logic file conversion as a service for a nomimal fee. Just email me your project file. See details here:

http://www.pianojoe.de/logic-converter/

Greetings from Germany!

Joe
 

Markdvc

Administrator
Staff member
Current versions of Logic Studio can't access very old Logic files (<V.7).

FTR, current Versions of Logic can open Files from Logic 5 or newer. Projects from Logic 4 or earlier must be opened and saved in Logic 5, 6 or 7, after which they can be opened in 8, 9 or X.

kind regards

Mark
 

mt100uk

Logician
I can open 7/8/9/X tracks in X but only 8/9 in logic 9 curious... Anything older I think you'll need a legacy version
 
Top