Logic Pro 9 Cycle Record Comp Folder Problem


I've been using Logic for over ten years but I'm currently confused by how Logic is responding and wonder if I'm encountering a bug or I've accidentally re-set a preference.
When I Cycle record I usually end up with one folder of takes that I can swipe between to comp.
Now what seems to be happening is that for the first few cycles it puts these into a folder just fine and then starts stacking take after take with each on it's own copy of the same track.
Any ideas?

I'm totally at a loss....:brkwl:
Unfortunately not I erased the takes I didn't need and moved on.
However the problem is exactly as I described it.
The first three cycles are in a folder that I can swipe between, subsequent cycled takes start to stack up above that, outside of the folder, on their each copy of the track, muting each take as the next cycle starts.
So what I end up with is a folder of three cycles and however many subsequent tracks depending on how many cycles are allowed before I hit stop.
I can swipe to comp on the takes in the folder. The ones outside the folder require the old scissors and move technique.
This is not the first time this has happened but is a fairly new problem and doesn't happen in every song. Just occasionally. I'd say about three or four times over the last thirty or so songs.
This is why I'm pretty sure it's a bug.
However, if you could direct me to where I set the preference for how Logic deals with cycled takes I could try switching it on and off and seeing if it cures the problem.
Upvote 0
Ok here's ya screenshot!

It's done it again with a new song.
All the bass takes you can see here came out of one attempt to cycle record.
As you can see, at the bottom, the first three passes are in the folder. The last two are separate but all on Audio track 2.


  • Screen shot 2012-09-18 at 20.45.30.png
    Screen shot 2012-09-18 at 20.45.30.png
    16 KB · Views: 161
Upvote 0
Very strange.

I can't reproduce it in either 10.7.4 or 10.8.1 with L9.17.

Settings(upper left tool bar)>Record parameter settings only deal with cycle record in MIDI. Logic is designed to automatically create a "take folder" when audio is recorded in cycle mode.

What specific version of OSX? L9?

If you're using L9.1.7, there's a Provide Logic Pro Feedback item in the Logic menu that will take you directly to apple.
Upvote 0
Also, do you run Cocktail or Onyx maintenance routines?
Trashed Logic preferences? (Use the menu item in the Logic menu (L9.1.7))
Upvote 0
I'm using Logic 9.1.7 running 64 bit on a Mac Pro 2.66 Quad Core Intel Xeon running 10.6.8

Don't have Cocktail or Onyx but I do run Yasu every couple of weeks.

I'll try trashing Logic's prefs. I forgot that ol' favourite! ;-)
Upvote 0
That didn't seem to work....
Gotta kick in the head for today as I've been on here for ten hours straight now.
Beer is calling ;-)
I'll see what it's doing after a re-boot (of Mac and brain)
Thanks for all your kind suggestions
Upvote 0
A fresh start after a reboot makes sense.

Other things that cross my mind...
-last time you did a backup/erase/clean install?
- if the above seems ridiculous, then how about a clean install of OSX and partial install of Logic (minimal instruments, loops etc to save time) on a spare external drive to see if things work properly. If the problem goes away, then the first item becomes a procedure to consider.

Enjoy the peas of mind with good brew:thmbup:
Upvote 0
This does seem very strange and I'm with Wally on this one - it looks like some sort of corruption of the prefs or something similar.

One little workaround, certainly not a solution though: you can pack all those loose takes into your take folder after the recording. There is a "pack take folder" key command that should do the trick.
Upvote 0
Well, it's still a problem. And a really really annoying one at that.
As I say first three cycles always go into their folder for easy 'swipe' comping. Subsequent passes manufacture their own copies of the same track, muting the preceding take as a new pass starts.
When you hit Stop you end up with a folder containing the first three passes - unmuted, and the last of the passes on their own track is also unmuted.
This makes it a total pain in the ass to try to comp between the old system and new 'swipe' system!
I can't think of what I'm using that may be causing it unless the Slate Digital VCC has stuck a bug up Logic's butt....
Upvote 0
Oh and trashing the prefs didn't work.
I even tried replacing the prefs with an old set from a back up drive before the problem started.
Bit nervous of a clean install as I have days worth of programs to re-install and I'm not even sure I have all the required updators for each prog.... :-(
Upvote 0
What happens if you record using the OSX Built-in Mic or Input vs your hardware interfaces?

Short of a clean install, try this:
- Quit Logic.
- Create a folder named Components-X on your desktop or in the Plug Ins folder.

- Go to HD>Library>Audio>Plug Ins>Components folder. Select all of them, then drag them into the Components-X folder. There's no harm in doing this.

- Also create a folder of a different name like User_Components for any AU plug ins in your User>LibraryAudio>Plug Ins>Components folder. Drag as above but into the User_components folder.

- Start up Logic, then try cycle recording. If the problem goes away, then there is an errant plug-in.

- At this point, you can start to drag back in critical plug-ins, restart Logic, test. If Ok, then keeping adding more back in.

The strategy above is called for when incompatible plug-ins crash Logic. But that's not really the case here.

If the above doesn't change how Logic functions, I would still encourage you to install your OSX and a basic Logic install on an empty partition or ext hd. If Logic works, then you know for certain something is corrupt or incompatible.
Upvote 0