Logic Pro 8 Delay with Samson CO3U USB microphone on Logic Pro 8

#1
Hi can you please help? I am having a problem with my microphone having a delay when recording vocals. It's the Samson CO3U Usb microphone and I've managed to get it working but I'm having a problem with the mic delaying when im recording vocals. I'm using Logic Pro 8 and don't understand why this is happening. Can anybody please help? :(
 

Markdvc

Administrator
Staff member
#2
THis probably means that you need to adjust the I/O Buffer setting.

Go to Logic -> Preferences -> Audio

- then try a lower setting, start off with perhaps 128.

kind regards

Mark
 
#3
Ok thanks Mark, I will try that and see where I get with that. Do I tick Safety Buffer?? And also do I set the recording delay to Zero on the audio page?

Thanks
 
#6
No luck

Hi. I tried what you said last night but it still didn't work. It seems to work for a few minutes then the delay starts again. Any other suggestions? Is this a common problem with usb microphones?

Thanks
 

Eli

Logician
#7
Hi. I tried what you said last night but it still didn't work. It seems to work for a few minutes then the delay starts again. Any other suggestions? Is this a common problem with usb microphones?

Thanks
Are you maybe putting some latency inducing plugins in your signal chain somewhere "after a few minutes" once you have a track or two down? If so, check where they are in your signal pathway and set your latency compensation accordingly. This may or may not be the source of the problem.
 
Top