Logic Pro 9 'Disc is too slow.(record) (-10004)


For the first time on my system I tried recording 3 mic sources ( + 1 MIDI) at 96000 Hz ( 24 bit)

Previously I had used this sample rate for single passes.

After a few moments L9 would stop with the warning as per subject line.

The audio was streaming to 320G Hitachi internal drive
I then tried an internal type-0 RAID pair of Hitachi 250G each.

Same dead stop.

I proceeded at 44100 Hz with no problems.

Is a normal serial-ATA 7200 rpm drive insufficient to record multitrack at a sample rate of 96000, even when paired as a type 0 RAID? Or is there something amiss with my configuration?

Mac Pro 2.66 ( early model)
OSX 10.6.4

i had a similar experience recently on my first attempt at 96khz 24bit on my MBP 15" C2D 2.33,
2GB ram recording to a FW800 500GB 7200drive. 10.6.3 L9.1.1 motu traveller

ive never tried it on my MP.

i got 3 mono tracks that would record for ~ 3 minutes then throw up that same error. after about 30mins of that.. i went back to 44.1 and it was fine ( but worthless for the project)

so i cant help with an answer but can verify the problem, with something in the chain.

please post what you find.

Upvote 0
Seriously, this is the same old problem Logic users are plagued with since decades.
The bad thing being (probably also for the programmers) that it happens more or less randomly. At one point in time I can record and playback almost as many tracks as I want (mind you, I'm not working at anything higher than 44.1, my opinion is that it's rather pointless unless you're using the most highend studio equipment, too...), and then there's those occasions when Logic would stop while just recording a single mono audio track.
And I'm sure it doesn't have much to do with recording at 96kHz, either. Sure, the system load is gonna be higher, but come on, 3 tracks? Even a 10 year old computer should be able to manage that more or less with ease.

You may want to check with another host. For instance, Reaper. There's a completely uncrippeled (and almost unlimited) demo. In case it manages to record those tracks, then it's clearly a Logic issue.

However, have you tried experimenting with different disk buffer sizes?

- Sascha
Upvote 0
Hoi Sascha, George, thanks for responding.
If you mean the I/O buffer, it's set to 128.

Jon Hiseman suggested that I check whether my RME Fireface is connected via 800 mbs FW with no 400 in the chain and I see it is connected via 400 so I'm rebooting now but will post this first

Upvote 0
If you mean the I/O buffer, it's set to 128.

Oh, I just noticed there's no separate disk buffer anymore in L9.
However, you may want to fool around with this option, too:

- Sascha
Upvote 0
Warning: do not set this buffer to large. I have known people system to become unusable when set to large.

I know. These settings are quite "oxymoron-ish". You never know what'll happen. Basically, one would think that a "large" processing buffer would probably help things on their way, but quite often the opposite is the case.

- Sascha
Upvote 0
I've changed the processing buffer size to 'medium', connected to my RME FW 800 port and have decided to revert to 44.1 for future projects until such time as they introduce 88.2 as a standard :)

Upvote 0
I think that's a wise decision. Really, unless you have massive problems with some plugins aliasing (which often gets way less at higher samplerates) and/or use absolute highend equipment to feed your soundcard, I don't think working at anything higher than 44.1 (or 48, if you do a lot of movie work - fwiw, I still don't get it why they use 48 in that area so often) is making too much sense.
And then, especially in case you're using quality equipment, the signal should be good enough for just about any professional purposes at 44.1, too.
And regarding plugins: Most newer, properly developed ones feature some internal interpolation algorithms to avoid aliasing at lower samplerates, so that shouldn't exactly be an issue, either.

- Sascha
Upvote 0