Does Anyone Here Use Sibelius, if No Then Don't Open This

sus4

Logician
I'm trying to open a score that I created earlier this year and I'm getting an error message saying: "There was an error opening this score. This score was created with a newer version of Sibelius. You need to update Sibelius to open it." I got this version this year which is version 8.4.2. and I'm pretty sure I created this score with this new version. This doesn't make sense to me. I do have a printed copy of the score which I printed out when I wrote it this year. I don't want to have to re-enter the score into Sibelius from the printed score that I have. That's a job to do.
Anyone understand this or ever had this problem.
Thanks
 
Top