Logic Pro 9 Environment - cabling between layers causes crash

Hello everyone! This is my first post. I have been on the yahoo list for years.

I'm not sure if this is a bug or not but I've come across this (hope this explanation makes sense):

There's a template in LP9 in Compose called Electronic. It has a nice thing in it called MIDI Effects. I made a much simpler thing in the past to do the same thing, ie create MIDI effects, usually an arpeggiator after the physical input, but before the Sequencer input. Mine is a simple has a Physical Input wired into a cable switcher which uses three buttons to switch between input thru, arp and a delay, which then all trundle off the the sequencer input.

Apples one is the same idea, yet much more sophisticated. Have a look. Anyway I notice in theirs they have the physical input on the Clicks & Ports layer, which is cabled through to a transformer on a layer they have called MIDI Effects. All good. I though that was a great idea, so I tried the same on my simple one. So I put the Physical Input back on the Clicks & Ports layer and tried to cable to my cable switcher by holding down option on the Physical Input, but my cable switcher can't be seen in the menu anywhere. So I tried to simply open two Environment windows and cable that way. As soon as I drag the cable from the physical input into my cable switcher BANG! Crash. Logic disappears and the crash notice comes up. I tried it in Apples template as well, ie I removed the connection between the Physical Input and their Transformer and then tried to reconnect by dragging between layers and it crashed. It seems I can cable to some things by dragging across layers but not others, like instrument objects, the sequencer input etc. But as soon as I try a cable switcher or transformer it crashes. 100% repeatable everytime. I realise maybe this not allowed or something, but if that's the case how did Apple get a cable connection between the physical input on one layer and a transformer on the other in the first place? Also why can a physical input cable into a transformer or cable switcher on the same layer and not between layers? Also why when holding down option on the physical input can't it see all objects present on another layer? Bugs? Any idea?

Hope that makes some kind of sense....

Leon Horrocks

MBP 3,1 4GB RAM, LP9.0.2 OS10.6.1


... tried to cable to my cable switcher by holding down option on the Physical Input, but my cable switcher can't be seen in the menu anywhere.
When you create a cable switcher, by default it is 'invisible'... next time you create one, tick the 'icon' box in the parameter section on the left and it will become available for cabling via option-click

Fixing bugs in the environment is way down the list of priorities for the Logic developers I'm afraid - their focus is on pimping Logic to entice Garageband users to trade up. The environment will probably be left just the way it is for the foreseeable future.
Upvote 0
Thanks guys that really helped me out. So cabling between layers with some objects is buggy. Thanks for the Icon tip ibt, that vaguely rings a bell. I haven't delved into the environment for a bit. Worked perfectly for what I wanted to do, so many thanks.

As a side point it's a pity Apple don't fix these things. The environment can be really useful, and some of the things we can be fun. I know its probably not as important as it used to be as we do a lot in audio and with softsyths now, but its still cool.
Upvote 0