Environment's Physical Inputs bug

FUBARd

Logician
It seems the Logic Pro X Environment's Physical Input box (within the last version or two) has been 'broken' as its now set static at only 14 physical input devices including 'sum'. Have a 16 input interface like the Mio-10 or two of the more popular 8 I/O interfaces? It only shows 'sum' & the first 13. Plug more USB midi devices in and it'll either bump out ones previously represented or just not show up.

I tried every step on Apple's website from deactivating plugins to trying a clean user login, unplugging gear up to and including pulling my Apogee PCIe card! Nothing makes a difference! Of course, I open Ableton or Machine in standalone & theres no issue at all. Funny thing; all the attached midi devices's midi notes DO come through the 'sum' line but theres no way to route them individually as they're not being shown on the Inputs box.

Apple support said they won't help me because the environment isn't supported. (dafak)

I have some funny pix to display exactly what its doing. Just look at how the Mio-10 only shows its first 13 inputs, then the MPK gets hooked up & bumps some of the Mio's out, then Machine bumps out one, as only its first input is displayed. Thats extra weird since Machine has three but only the one is bumping out others. Where are the rest? Hiding w the other non-shown ones I guess lol!

Ugh I'm dying here. I bought & spent 10 yrs learning Logic specifically for its detailed midi routing capabilities & now THIS.

Anyone else have this issue or know how to fix it?

Just the Mio 10 w/ 1st 13 represented in Environments


Mio10 w/ MPK61 pushing out some of Mio's inputs


MIO10, MPK & Maschine w/ Maschine only pushing out a single one (odd)
 

FUBARd

Logician
Ive successfully reproduced the issue with my laptop running the same versions of OSX 10.11.6 & Logic 10.3.3
Only 13 input devices allowed :-/

Gee I really hope this gets fixed!
 

FUBARd

Logician
Hahah yeh that was the absolute first thing I tried. Unfortunately, and quite strangely, the box wont change in size no matter where I try to grab it. I clicked & declicked the cable protect option as well. Its the weirdest thing. On the plus side, whateverthe issue is, its no longer an issue shortly after an OSX update but returns after 30min or so. Crazy huh? Ive decided to backup, nuke & start again from scratch. This is exactly why I keep seperate system & media drives. Shouldnt take but a day or two lol
 
Top