Logic Pro 9 Express 9 and Magical 8bit Plug

LE9user3

New Member
Hi everybody.

I'm really struggling with trying to get the "Magical 8bit Plug" plug in to work with Logic Express 9.1.1.

You can download the plugin here:
http://www.ymck.net/magical8bitplug/index.html

I've downloaded the Universal Binary version, as I'm running an Intel based Mac.

I download the file, and place the component in Macintosh HD > Library > Audio > Plug-Ins > Components

When I load up Logic Express, I then go to the Audio Units Manager (Logic Express > Preferences > Audio Units Manager).

I can see "magical8bitPlug" available to check, and it is "successfully validated".

When I go to the inserts buttons (that pulls up the menus of various effects), and go to "Audio Units" menu, only the default Apple plugins appear. On all the instructions and tutorials I can find, I've followed every step and installed everything properly, and I can't for the life of me figure out why it won't show up. Here's one of the tutorials I've tried:
http://www.youtube.com/watch?v=pMEBeOZF7L4

I've tried running Logic in both 32bit and 64bit just in case, I've uninstalled and reinstalled the component...

Any ideas? Am I missing something extremely simple here? I've been looking up tutorials and experimenting for a few hours now and I can't find anything about it 'successfully' installing but not showing up.

Thanks for any and all advice. It's much appreciated.
 

pkm

Logician
If I'm not mistaken, that plugin is a software instrument. Create a new software instrument and replace the exs with the magical 8bit plugin from the input area, not the inserts area.
 

LE9user3

New Member
!!

pkm, THANK YOU!!! I've wasted so much time, missing the simplest thing. *smacks forehead*

Thanks again. It's working great now!
 

JWrecording

New Member
I am having a problem getting the 8BIT AU to work. I am running the newest version of Logic Pro 9. Every time I try to load it, however, I get this message:
validating Audio Unit Magical 8bit Plug by YMCK:

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
AU Validation Tool
Version: 1.6.1a1
Copyright 2003-2007, Apple, Inc. All Rights Reserved.

Specify -h (-help) for command options
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

--------------------------------------------------
VALIDATING AUDIO UNIT: 'aumu' - 'synt' - 'ymck'
--------------------------------------------------
ERROR: Manufacturer OSType should have at least one non-lower case character: 'ymck'
ERROR: Cannot get Component's Name strings
ERROR: Error from retrieving Component Version: -50

* * FAIL
--------------------------------------------------
TESTING OPEN TIMES:
FATAL ERROR: didn't find the component


validation result: couldn't be opened

It is strange though, because the plug-in still works....
does anyone know why this is?
 

daveyboy

Logician
This thing is awesome!!! Well, awesome at easily getting cheesy old Nintendo game sounds. Just wrote an opening to a song I'm producing using it.
 
Top