Logic Pro 9 Flex Time causing imported audio to move


New Member
Here's one I can't figure out. I recorded a drum set (5 mono tracks and one stereo track) in Digital Performer and imported the audio into Logic to touch up the timing. The song has several tempo changes (it starts at 135 bpm) so I successfully imported the Standard MIDI File from DP into Logic before I imported the audio. All of the imported audio tracks are exactly the same length. I also used the Remove Tempo Information from Audio File in the Options menu in Logic on all of the imported audio files before I dragged them into the Logic Arrange window.

Once all the tracks are in the Arrange window (all starting at bar 1, beat 1) I enabled Flex Time. The I chose Slicing for each track.

The audio within each track, except for the stereo overheads track, gets moved later in time by about a beat and a half. The stereo overheads track stays where it should - where it started. The waveforms within the blue blocks move later and the playback is later BUT the blue blocks (sorry for my poor terminology) still all start and end in exactly the same place and are all together - even the stereo track.

If I turn off Flex Time all the mono tracks stay in the wrong place. But if I choose Off instead of Slicing on each track, they go back to the correct position. I've tried all of this with and without the tracks grouped and phased locked with the same results.

If anyone has a solution I'd be very appreciative. I've spent the majority of the day today troubleshooting this with no luck.

Thanks very much,

Logic Pro 9.1.5
Mac OS X 10.6.8
Mac Pro Intel 8 core with 12GB of RAM


don't know if you've tried this, but whenever Logic is acting weird, I trash the logic preferences file (be sure to save your key commands on the desktop-or someplace where you can find them-before doing this, or you'll lose them)

restart and open the song again...this nearly always fixes whatever weirdness is going on. You could also try copying the entire project to a new folder.
Upvote 0