Logic Pro 9 Flexing drums, why is stereo overhead track not Flexing?

#1
Hi folks, I have multi-tracked live drums and have assigned them all to the same Group, then turned Flex on, then selected "Slicing". All tracks seemed to get analyzed for transients, BUT for some reason the stereo overhead track does not "gray out" and show the transients.

To further confirm it has not been properly included in the Flex, when I move a transient marker on a Q track, all other tracks adjust their transients EXCEPT the stereo overheads track does do anything. What's wrong with that stereo track such that it is not showing its transients and being included in Flex? Doesn't Flex work on stereo tracks?
 
#2
Okay, so I tried something that mysteriously worked...

I changed the stereo linked track to a mono track (i.e unlinked it) then turned of Slicing (which disabled Flex on all grouped tracks) the turned Slicing back on and the transient markers then appeared on that track.

Finally, I turned on the stereo link again to make it a stereo track, and the markers stayed visible. The track now seems to Flex properly when I move a marker on a Q track.

Anyone know why the problem existed in the first place, and why this fixed it?
 
Top