Logic Pro X From Mojave and LPX 10.5.1 to ... ?

cl516

Logician
Hi all, been stuck on Mojave and Logic Pro X 10.5.1 on Late 2015 iMac.

With an interface upgrade this weekend, I'm finally eligible to update software.

Thinking to just get the Mac up to Catalina.

Is there a generally accepted safe version for Logic? Stay 10.6 or just go all the way 10.7.2?
 

Markdvc

Administrator
Staff member
If you go to 10.7.2 you will need at least Big Sur. There is a list of compatible Logic and OS versions in our FAQ.

If you are using much in the way of 3rd party audio units, always worth checking these for compatibility with the current MacOS Version before updating.

kind regards

Mark
 
Upvote 0

cl516

Logician
If you go to 10.7.2 you will need at least Big Sur. There is a list of compatible Logic and OS versions in our FAQ.

If you are using much in the way of 3rd party audio units, always worth checking these for compatibility with the current MacOS Version before updating.

kind regards

Mark
Thank you Mark! I’m thinking my next safe step might be to Logic Pro 10.6.3 and MacOS 10.15.7.
I’ve kept my 3rd party AU’s up to date.
 
Upvote 0
Top