Logic Pro X Guitar Audio input issue

Pascal

New Member
I''l try to best describe this issue since I have not found any answers online or on this forum.

A bit of context first: I've been a long time playing musician and was even a recording artist in the 90's but life took another path and so did music. About 4 years ago, the bug to write and compose came back so I decided to get the home studio going. I bought a controller, the UR242 and that came with Cubase LE. Tried Cubase for a while but then I started reading up on Logic Pro X and with all the features & price that became a no brainer. Logic Pro X it is.

Now to my guitar audio issue: If no DAWs are open and I plug a guitar in any of the inputs of the controller I will hear the direct guitar sound. I imagine this is correct functionality since the sound input in OSX calls for the Steinberg UR242. When I launch Logic, the direct sound can still be heard. If I add an amp and change the sound I will hear both tone (Direct clean and process sound from track) If I mute the track, the track mutes but I still hear the "direct" clean sound.

If I launch Cubase, the guitar sound disappear and I can use the software as intended: I can create a track, hear the guitar, mute etc. When I quite Cubase, the original clean guitar sound does comes back. So my work around so far has been to launch Logic Pro and then launch Cubase to use Logic properly. When I do that, I can create a processed guitar in Logic that won't have that clean direct tone always playing.

I'm pretty sure this is not correct functionality, I've searched for an answer but haven't been successful. Any idea what the issue might be?

Thank you
 

Peter Ostry

Administrator
Staff member
Generally: What you hear from the interface without a DAW is "direct monitoring". This is used to hear your own sound while you play, with almost no latency (only the latency of the interface) and is often the preferred technique for recording. Now, if you open a DAW, you still hear the direct signal from the interface, plus all sounds coming from the DAW. The signals get mixed in the interface. If you want to hear the DAW only, you have to switch direct monitoring off. Some interfaces have a knob to mix direct and DAW sound, most interfaces use control software and an internal mixer.

The UR242 is special due to it's tight integration for Cubase. In other words: Steinberg Cubase talks to Steinberg UR242. You can switch direct monitoring on and off in Cubase's device settings. Unfortunately the UR242 manual does not tell how to do it otherwise. If you don't find this setting in the control software and cannot use the built-in mixer for that, you may ask Steinberg how to switch direct monitoring without Cubase.

Probably another option is, to launch Cubase and switch direct monitoring off.
From the manual:
[Devices]—>[Device Setup]—>[Steinberg UR242]—>Checkmark "Direct monitoring"
Then close Cubase and hope that the setting got stored in the interface and does what you want.
 

Pascal

New Member
Peter, thank you so much for the answer and suggestions! Makes sense. I'll try the suggested option, if not I will look for a Logic Pro frendly controller.

Cheers and many thanks.
 
Top