Logic Pro X How do you shut off "inactive flex marker" message?

normbias

Logician
I have a message window pop up constantly since updating to Logic X and wonder if anyone knows why it is happening and / or how to shut it off?

"This region contains inactive flex markers, which will be deleted if you perform the edit. Are you sure you want to edit the region?"

It happens in sessions that I have never turned on Flex globally or on individual tracks. Flex is not on. Having to click this box after every single file length change is a real annoyance but I can't see where track is getting Flex data from.

Any advice would be appreciated.
 

Eli

Logician
What kind of template are you starting from? is ti possible you built a template from a project that may have inadvertently had flex enabled?
 

normbias

Logician
It is possible but I don't think that is the case. If i did happen to have it on at any time, there still should be a way to disable a message that happens with every edit I do by changing file's visual length.
 

normbias

Logician
If I turn Flex on in the menu strip just above the track header, it shows a few flex pull-down menus in track headers that show as selecting monophonic. Some say 'select flex mode'. Flex mode isn't turned on in any of the individual tracks. Just now was the first time I turned flex on in this song. When I turned the track flex on, it went through analyzing of file so I don't understand where it was reading inactive flex markers from when there weren't any (at least not visibly) flex markers there. I'll try deleting those and see what happens.
 
Top