Logic Pro X How to stop auto-renaming of tracks & environment channel strips?

coffee_boy

Logician
I'm sure this is something extremely simple to fix but after spending hours with no luck I thought I'd turn to the experts:)

In the arrange window & the environment window, I like to have my tracks and channels names as Audio 1, Audio 2, Inst, 1 Inst 2....etc, etc.and locked with these names.

But when I drag in an apple loop or audio file to the arrange window it automatically re-names the track and the channel strip in the environment to the name of the apple loop or audio file that I dragged in there. How do I stop this from happening.......I've tried messing with all the preferences but I can't seem to fix it.

I'm sure this is a simple setting that I'm missing........anyone have any ideas.


I'll be eternally grateful as this is driving me INSANE!!!!! :)
 

Eli

Logician
Check out the naming options in the Configure Track Header window. You set the behavior there. You can get to it by control clicking in the Track Header.
 

coffee_boy

Logician
Check out the naming options in the Configure Track Header window. You set the behavior there. You can get to it by control clicking in the Track Header.
Thanks. I checked and selected "Channel Strip Name" under Additional Name Column and that has kept the track named as Audio 1, Audio 2, etc. in the arrange window, which is great. But it still auto renamed the channel strip in the environment window and the mixer window. Do you know if there is a way to stop that happening?
 

Eli

Logician
Did you try "Channel Strip Name" in the first column instead of the Additional Name column?
 

Eli

Logician
I think this has changed in Logic X. I'm fairly certain you used to have naming options for both the main name and the additional name. I'm not in front of my computer to check right now though.

Try going to File > Project Settings > Audio, and turn off the auto naming of channel strips option there. That may do it....
 

coffee_boy

Logician
I think this has changed in Logic X. I'm fairly certain you used to have naming options for both the main name and the additional name. I'm not in front of my computer to check right now though.

Try going to File > Project Settings > Audio, and turn off the auto naming of channel strips option there. That may do it....
Yes, I've already done that and they are switched off(see attached) but it keeps happening......could this be a bug?
 

Attachments

Colin Shapiro

Logician
This auto-naming behaviour doesn't happen for me. I have the same settings as you do, and when I drag an audio file or an Apple Loop onto an existing track, the Environment and the Mixer both keep Audio 1 (for example) as the name.

In cases of odd stuff like this, I'd always recommend running the usual repair routines like DiskWarrior (if you have it) and Disk Utility, when booted from a separate partition. Then repair permissions and see if it still happens....
 

yavuz

Logician
I used to get EVP88 when I create new instrument...
I think it happened once after moving on to Logic Pro X...

Is this something related?
 

coffee_boy

Logician
This auto-naming behaviour doesn't happen for me. I have the same settings as you do, and when I drag an audio file or an Apple Loop onto an existing track, the Environment and the Mixer both keep Audio 1 (for example) as the name.

In cases of odd stuff like this, I'd always recommend running the usual repair routines like DiskWarrior (if you have it) and Disk Utility, when booted from a separate partition. Then repair permissions and see if it still happens....
I called tech support and ended up having the case forwarded to a senior tech. Luckily his computer was acting in the exact same way as mine so he was having the same problems with automatic naming of tracks. He is taking the case to the software engineers to see if they can get to the bottom of it and will get back to me.

I'll post an update if I get it fixed. Thanks everyone for your help!!:)
 

Eli

Logician
FTR, I find that when I create tracks without opening the library, and call up everything myself. The naming remains under control. But when I open the Library when creating new instruments, that's when all the renaming nonsense starts going crazy.

So, I am experiencing it too, but not under all circumstances.
 

coffee_boy

Logician
FTR, I find that when I create tracks without opening the library, and call up everything myself. The naming remains under control. But when I open the Library when creating new instruments, that's when all the renaming nonsense starts going crazy.

So, I am experiencing it too, but not under all circumstances.
For me, it happens both with 'open library' checked or unchecked.

I've found a workaround for now:

I inserted a small muted audio file on the zero bar on each of my channels in the arrange window then renamed the channels Audio 1, 2 etc. and saved it as an autoload. If there is already a file on the channel then it doesn't automatically rename when you add another audio file. It's not ideal but will work for now.

Thanks for your help.
 

HKC

Logician
Maybe this is the same thing but is there a way to turn off the feature where the channel takes the name after the name of the preset. For instance I often use Superior for drums and end up with a track called "Untitled". I could of course name the preset but maybe there is an easier way.
There are non of the suggestions in this thread so far that solves this. It's not a Logic X thing, it's been there for at least as long as 9.
 

coffee_boy

Logician
None of the suggestions in this thread so far solve this. It's not a Logic X thing, it's been there for at least as long as 9.
Yes it was there in Logic 9 also. Here's something weird: I went over my my friends studio who has just started using Pro X as well and tested it to see how his reacted. His is working in the exact opposite manner. He's never had a problem with automatic naming of tracks in 9 or 10, his tracks always remain named as Audio 1, Audio 2 etc. so we tested his system in Logic 9 & Pro X and no matter whether 'Automatic Naming of Channel Strip Objects' was checked or unchecked we couldn't get any of his channel strips to rename.....in any window.
 

HKC

Logician
It's a good thing that you have posted this. It has bothered me for quite some time but never enough to actually do anything about it :)
 
I have always had the track rename when I dragged a loop into a track.

That said, there is a way to enable you to see both of the names available in a track by selecting that option when you alter the track header information (where you can also enable or disable things like freeze, solo, color being shown, etc). You can edit the 2 names there...

Also, it seems that Logic 9 will randomly select whichever name it wants when recording a track, at least in my experience.
 

coffee_boy

Logician
This auto-naming behaviour doesn't happen for me. I have the same settings as you do, and when I drag an audio file or an Apple Loop onto an existing track, the Environment and the Mixer both keep Audio 1 (for example) as the name.

In cases of odd stuff like this, I'd always recommend running the usual repair routines like DiskWarrior (if you have it) and Disk Utility, when booted from a separate partition. Then repair permissions and see if it still happens....
I ended up talking to a senior tech at apple. His program was acting the exact same way as mine and was 'auto naming' channel strips even when the preference was turned off. He say's that's the way the program is supposed to act and there is nothing wrong with it.

I'm pretty certain this isn't true as half the people who have commented here are not having the same problem.......their's doesn't automatically rename. My production partner has the same set up as me and his doesn't re-name so something is wrong somewhere.

I suppose this just has to go down as an unresolved problem?
 
Top