Logic Pro (X) How to stop MIDI data from being input to Logic Pro.


I have recently acquired a USB/MIDI CV/Gate Module (Doepfer A190-4) for my modular system. The problem I am having is that when I try to record into a Logic Track via a MIDI keyboard using the USB connection I get all sorts of feedback MIDI loop from the device. Since the Device does not allow me to turn it's output OFF in the Audi MIDI Setup app (both IN/OUT are grayed out), I was wondering if there was a way (possibly in the Environment of Logic) to disconnect the MIDI being output from the device and into LOGIC. In short I want the device to only receive MIDI but not transmit (or if it is transmitting for Logic to ignore it). Logic Pro 9 had a MIDI Thru setting you could turn OFF but I dont see this setting in LOGIC PRO X so I thought maybe the Environment would be the place to look but Im not very familiar with using Logic's Environment.
Try going to the Click and Ports layer. Create a "dummy" monitor object from under the new menu. Then, on the Physical Input object, drag a virtual cable from the node corresponding to the device whose input you want to kill, and connect it to the dummy object. This will effectively break the connection and prevent it from reaching Logic's sequencer input.
Upvote 0
Open the MIDI Environment and switch to the layer "Click&Ports". The big object to the left is the Physical Input with a list of all devices currently used. If only the SUM port is cabled to the Logic Sequencer, all incoming data are going through this port. If you connect one or more of the individual ports to any Environment object, incoming data from this device will use this port only.

Two basic methods:

1. Channel based filtering

In the screenshot below I used the SUM Port and blocked all notes on MIDI channel 1, everything else goes through. For different behavior, use other transformer settings.


You can only use this method, if there is no other device sending the same events on the same channel. For example a keyboard. You would block this device also.

2. Port based filtering

Here I connected one port of the Physical Input to a monitor object. Since the monitor is not cabled to anything, the incoming data of this device will simply vanish.


Be aware that Logic may remove cables from the Physical Input if your MIDI setup changes (number or order of devices). In such a case just re-cable your port and you are fine.


You can combine both methods by processing MIDI at an individual port and cable the last stage of your patch also to the Sequencer Input (additional to the SUM cable).


Ah, Eli was faster and his explanation much shorter.
However, enjoy the pictures
Upvote 0
Thank you Eli and Peter for the quick responses.
I may still be missing something in the process because when I create a dummy "monitor" in the Environment and attach my nuisance MIDI Module I lose the ability to record onto that track. I still need to be able to Output MIDI events via my MIDI keyboard to the aforementioned instrument BUT not receive any MIDI data. The name of the instrument and the "Record" button disappear when I make the dummy "monitor" connection.
Upvote 0
A quick followup with success this time!
I believe I had something incorrect with the wiring...those tiny output nodes are nearly impossible to tell apart!
I was able to achieve exactly what I wanted and I thank you both for your assistance!

Cheers! :)
Upvote 0
Glad it worked! And yes I agree, the graphics of the physical input object are horrible. They really need to be updated to make things easier to see clearly.
Upvote 0