Logic Pro X Klopfgeist No sound during count in and record?

BigQStudios

Logician
Hello friends, This is my last issue then it's off to the races. First a question: Is klopgeist a default setting or is it something I can bypass or turn off and still have a click? I am still learning this software. I'm still not hearing a click during record or count in. The click is very audible during playback. I've done some reading and watched some video's on youtube. I'm certain I have all the correct boxes checked in all the right tabs under both Program setting, Project settings, and metronome settings. What have I missed? Thanks..
 

CSeye

Logician
Klopgeist is a plug-in. Open the mixer and set it to All to reveal the click track.

Take a look at the Record menu>Metronome Settings. The Options section in the upper left lets you select when you want to hear the click.
 
Upvote 0

BigQStudios

Logician
Yes I've tried this to no avail. I have the correct boxes checked. What I did notice is that the last check box is OUTPUT selection. It is set to outputs 1 and 2. The only choices it gives is to run it on outputs 1 through 32 in stereo pairs. While the mixer window shows STEREO OUT in it's output pan. Now it bears mentioning that all other settings have my recorded audio and MIDI set to STEREO OUT and not OUT 1 and 2. I think I read somewhere that these are the same but I'm not sure. I have checked the Click during record, click during playback, and polyphonic clicks and simple mode turned off and only during count in turned off. I can hear it fine during playback but it goes silent during record. Input monitoring is set right because I can hear my guitar in record mode and record music just no click??? I'm pulling hair...
 
Upvote 0

BigQStudios

Logician
Yes I've tried this to no avail. I have the correct boxes checked. What I did notice is that the last check box is OUTPUT selection. It is set to outputs 1 and 2. The only choices it gives is to run it on outputs 1 through 32 in stereo pairs. While the mixer window shows STEREO OUT in it's output pan. Now it bears mentioning that all other settings have my recorded audio and MIDI set to STEREO OUT and not OUT 1 and 2. I think I read somewhere that these are the same but I'm not sure. I have checked the Click during record, click during playback, and polyphonic clicks and simple mode turned off and only during count in turned off. I can hear it fine during playback but it goes silent during record. Input monitoring is set right because I can hear my guitar in record mode and record music just no click??? I'm pulling hair...
I just found something the worked. Under the Record tab> Metronome settings, dialog window has a small box called "Port" it has 3 options: Off, All or X-USB. My interface is a digital board called X-USB in the program. I had it selected. Experimenting, I selected All and the metronome came to life during record.. I'm partying
 
Upvote 0

CSeye

Logician
No issues on this end with click during record with the following settings:
- Simple Mode, or Click while recording
- Port: Off
- Output: 1-2

I'm wondering if the routing in you digital board is at play.
In Logic's preferences>Audio>Devices tab, set the Output and Input Device to Built-in Output and Built-in Input. Use the metronome settings above. Do you hear the click when recording?
 
Upvote 0

BigQStudios

Logician
Ah! My friend CSeye that was a culprit. I can hear my click in Record Mode now. I had mine set on Click during Record and it did NOT click during record. I put it in Simple Mode and it DID click in Record Mode. Also the digital board is at play with it's numerous routing selections. For you guys and gals using a Behringer X-32 as your interface, set it up as follows: To record- Set inputs to CARD and Set card to LOCAL. For Playback Set inputs to CARD and Set card to CARD. If you own one you know what I'm talking about. Now these settings are a combination with the program settings and the board settings. If anybody has a better way, please share! Any other combination of settings and I can't hear my click in Record Mode. This seems to have resolved all my issues or just made them bigger..... Ha Peace!
 
Upvote 0
Top