Logic Pro 9 Korg Nano & Logic

edurbrow

Logician
Anyone have issues with Logic & Korg NanoKontroller? I just got this device and downloaded the driver, which I assume to be the latest, from Korg. However when I boot Logic, I get a message saying incompatible driver. Also, I'm not sure this is related, but for what it is worth, Logic is running really slowly, that is spinning beach balls all over the place and also getting Midi timeout notifications.

I cannot find where the nanoKontroller hangs out. I searched in Audio plug-ins at the root level and user level and couldn't find it. All I can find is the downloaded installer, so I can't say exactly what version I have.
TIA
 
AMS

Can you see the nanoKontroller in Audio Midi Setup under the MIDI pane? If Audio Midi Setup does not see the NanoKontroller neither will Logic, you have to make sure AMS sees it...

Audio MIDI Setup is found in your Applications->Utilities folder : )
 
Upvote 0

gdoubleyou

Logician
They released a specific plug for GB and Logic, but you need to remove the nanoeditor stuff.

Should look like this.
MAC:Software:nanoKONTROL_GB_Logic_Plugin.zip
 
Upvote 0
The drivers for this actually get installed into the Logic app it's self...

right click on the Logic Pro app,
select "Show contents",
open the "contents" folder and
look into the "MIDI Device Plug-Ins" folder

You will find the driver that is causing the issue there.
 
Upvote 0

edurbrow

Logician
Can you see the nanoKontroller in Audio Midi Setup under the MIDI pane? If Audio Midi Setup does not see the NanoKontroller neither will Logic, you have to make sure AMS sees it...

Audio MIDI Setup is found in your Applications->Utilities folder : )

Hey Eddie, you are over here too!
Yes, I could find them in Audio Midi Setup. They were between Midi Timepiece AV #54 and Midi Timepiece AV #55! I'm glad I looked, things were obviously messed up. I had been wondering why I'd been seeing those strange numbers of MIDI Time pieces in programs. Now I've gotten rid of all of the Midi Timepieces except #55 which was the only one that was active. Maybe that is what has been slowing everything down. Midi had been working so hadn't thought to look there.

I just opened Logic again and got the message:
Incompatible plug-in
Please update the nanoKontrol control surface plug-in.

The Nanos are all there in Audio Midi Setup, but they don't connect to anything. I guess that makes sense as they are USB devices.

The nanoKontrol does not show up in the Zone in Controller assignments in preferences.

I am getting the MIDI in/out indicater to move when I move a fader on the Nano but nothing is assigned.

Logic seems a lot more responsive in the short time since I've opened it. I did get a processor overload but I also have Digital Performer open too, so maybe I'm asking too much of this old 4 core.
Thanks,
 
Upvote 0

edurbrow

Logician
They released a specific plug for GB and Logic, but you need to remove the nanoeditor stuff.

Should look like this.
MAC:Software:nanoKONTROL_GB_Logic_Plugin.zip

i read that when I downloaded the file. I couldn't find any nanoKontroller stuff and I had never had one before. Does Logic 9 come with it pre-installed? Maybe I should start over.
The folder I downloaded reads:
nanoKONTROL_GB_Logic_Plugin
Inside is:
nanoKONTROL_CSPlugin_100.dmg
So that looks a little different. I just was at the Korg site a couple of days ago.... hmm.
 
Upvote 0

edurbrow

Logician
The drivers for this actually get installed into the Logic app it's self...

right click on the Logic Pro app,
select "Show contents",
open the "contents" folder and
look into the "MIDI Device Plug-Ins" folder

You will find the driver that is causing the issue there.

Which would be the microKONTROL.bundle, I take it. So re-install it?
Thanks
 
Upvote 0

edurbrow

Logician
I'm not sure this is related, but for what it is worth, Logic is running really slowly, that is spinning beach balls all over the place and also getting Midi timeout notifications.
TIA

I found the problem with speed. It was a firewire repeater/hub. Took it out and the speed went back to normal.
 
Upvote 0

edurbrow

Logician
Can you see the nanoKontroller in Audio Midi Setup under the MIDI pane? If Audio Midi Setup does not see the NanoKontroller neither will Logic, you have to make sure AMS sees it...

Audio MIDI Setup is found in your Applications->Utilities folder : )

I've come back to this problem.
In Audio/MIDI setup, The Nanos do not want to connect to either the Motu 828 or Presonus Firepod. I have a synth which connects to both.
Thanks again in advance
 
Upvote 0

edurbrow

Logician
In the Control Surface plug-in for GarageBand Logic EN.pdf it states:

If you are using the nanoKONTROL template for Apple Logic Pro (as downloaded
from the KORG website) Logic Pro/Express will not function correctly after
installing this plug-in. Therefore, delete the nanoKONTROL template for Apple
Logic Pro in the following order BEFORE INSTALLING THIS PLUG IN.
・Delete nanoKONTROL controller assignment information
From the menu, select "Logic Pro/Express" "’ "Preferences" "’ "Control Surfaces" "’
"Controller Assignments" and open the controller assignments setup window.
Select "nanoKONTROL" in "Zone" , push [delete] key on keyboard.
nanoKONTROL controller assignment information will be deleted.

The problem is that there is no "nanoKONTROL" in "Zone" even though I just ran the installer called: nanoKONTROL-CSPlugIn. I'm not sure if the template is equivalent to the nanoKONTROL-CSPlugIn. I never downloaded anything called template. Only the nanoKontrol plugin was available at the Korg site as far as I could see. None of the other nano controllers work either, though I did have them working somewhat when I first got them. I don't know what has gone wonky.
 
Upvote 0

Peter Ostry

Administrator
Staff member
This manual is just guessing.

To get back to a clean state, you need to remove the control surfaces and set the Controller Assignments back. Be aware that you will lose all your manual assignments.

If you use the control surface bundles that are available from Korg, do the following:


  1. Start Logic.
  2. From the menu, call Logic Pro -> Preferences -> Control Surfaces -> Setup
  3. Delete all of the nanoKONTROL icons you see there.
  4. Quit Logic.
  5. In the Finder, go to the file (user)/Library/Preferences/com.apple.logic.pro.cs
  6. Pull this file out to the desktop or delete it.
  7. Start Logic.
  8. Go to Logic Pro -> Preferences -> Control Surfaces -> Setup
  9. Manually install the nanoKONTROL control surfaces you need.
  10. Close the setup window.
  11. From the menu, call Logic Pro -> Preferences -> Control Surfaces -> Rebuild Defaults

If you have never installed and do not want the control surface bundles or (maybe later) decide to rather make your own controller assignments, do the same as above but leave out the manual installation in the setup window.
 
Upvote 0

edurbrow

Logician
This manual is just guessing.

To get back to a clean state, you need to remove the control surfaces and set the Controller Assignments back. Be aware that you will lose all your manual assignments.

If you use the control surface bundles that are available from Korg, do the following:


  1. Start Logic.
  2. From the menu, call Logic Pro -> Preferences -> Control Surfaces -> Setup
  3. Delete all of the nanoKONTROL icons you see there.
  4. Quit Logic.
  5. In the Finder, go to the file (user)/Library/Preferences/com.apple.logic.pro.cs
  6. Pull this file out to the desktop or delete it.
  7. Start Logic.
  8. Go to Logic Pro -> Preferences -> Control Surfaces -> Setup
  9. Manually install the nanoKONTROL control surfaces you need.
  10. Close the setup window.
  11. From the menu, call Logic Pro -> Preferences -> Control Surfaces -> Rebuild Defaults

If you have never installed and do not want the control surface bundles or (maybe later) decide to rather make your own controller assignments, do the same as above but leave out the manual installation in the setup window.

Thank you for pursuing this Peter.

I was able to follow your instructions. NanoKontrol now appears in the Controller assignments. Unfortunately it is still a dead piece of plastic. No light on it. The three Nanos are all grayed in Audio/Midi Setup. I'm not sure if it requires a restart. I'm falling asleep now so I'll attack this tomorrow.
Thanks,
 
Upvote 0

Peter Ostry

Administrator
Staff member
Unfortunately it is still a dead piece of plastic. No light on it. The three Nanos are all grayed in Audio/Midi Setup. I'm not sure if it requires a restart.
Grey Nanos means no Nanos. You see them grey because they were here, the Mac detected them at least once. You could even delete the grey icons without changing anything. They will pop up again, bright and colourful, if your Mac sees the devices.

Some hints in random order:

  • Restart the whole machine.
  • Log out and in again, this often fixes MIDI problems and is faster than a restart.
  • In Audio/MIDI setup, click on "Rescan MIDI".
  • In Logic, reset all MIDI drivers. I think this does the same as "Rescan MIDI" above.
  • Pull out and reconnect the USB plugs of the devices.
  • Pull out and reconnect the USB hub, USB as well as the power supply of the hub. When reconnecting, first connect the power supply, afterwards the main USB plug.
  • Use only good active hubs for USB-driven devices. Do not use passive hubs or the jack of your keyboard. All devices need power and your Mac isn't a power station.
Hope that helps.
 
Upvote 0
Just had the same issue with a client. Try disconnecting them, and then add them back into your system.

Remove all USB devices except keyboard and mouse.

If you are using a hub, remove the USB cable from it as well. The goal is to make sure all usb connections have been removed from the connectors, and I would suggest moving the cables as well.

Open "About this Mac" under the Apple menu, and then select "More info" which will bring up the system profiler. Click on the "USB" name, and you will see the usb bus, and all devices connected.

So, now add the hub, and check in the system profiler to see if it is there. if so, add the first korg device. Open audio midi as well, and make sure the korg is not grayed out.

continue adding in devices and checking to be sure they are being added correctly and also being seen by audio mid and the system.

that should work.
 
Upvote 0

Peter Ostry

Administrator
Staff member
continue adding in devices and checking to be sure they are being added correctly and also being seen by audio mid and the system.
Until tomorrow, when some device tries to hide again. ;)

Maybe we should add that an USB network with more than one hub cannot be called stable. I have always trouble with this stuff and it seems that I am not alone. Fortunately, as unstable as it is, it is also quite easy to get it back to work when you know the tricks. Annoying nevertheless. Where is the border between bug and feature...
 
Upvote 0

edurbrow

Logician
Maybe we should add that an USB network with more than one hub cannot be called stable. I have always trouble with this stuff and it seems that I am not alone. Fortunately, as unstable as it is, it is also quite easy to get it back to work when you know the tricks. Annoying nevertheless. Where is the border between bug and feature...

Good call. I was using the passive (!) USB Hub that came as part of the set with the Nanos. I unplugged the hub and plugged the three units directly in the computer and voila, all lit up and were un-grayed in Audio-Midi setup. Now to see about using them in Logic.

Thank you Peter & George, Eddie et al.
 
Upvote 0

edurbrow

Logician
Not only does the NanoKey work now, it works even when no music programs are open! I can't figure out where the sound could be coming from. Logic nor any other music/audio programs are open.
 
Upvote 0

Peter Ostry

Administrator
Staff member
I know this problem. Try Single Malt, Lagavulin for example although it is expensive. The Bourbon tends to make funny sounds.
 
Upvote 0
Top