Logic Studio apps Korg NanoKontrol2 (Not Working!)


Ummm where shall I begin? I was doing pretty good with Korg's NanoKontrol 2 and Then! I opened up a MS Concert and when I went to adjust the sliders (volume) noticed they seemed to be Not working right. Two sliders would move (volume in two channels) although it was the Master Volume slider at the same time etc. So, I had to go back and re-assign everything again. But, I lost all connection control. When I selected the slider or knob it turned red, once click on "Learn" it turned Blue and there was No movement at all.

I even tried to make a new Concert and Patches etc. and tried to assign the hardware, made the patch and tried to assign the sliders and knobs etc. Nothing moved. So, checked MIDI monitor...it showed the DX7 (Ch 16) which is correct but when I looked at the pulldown menu there wasn't any Device for Port A MIDISport 2 X 2 which is what the MidiMan connects to the DX7, but it should show Port A....instead it shows Port B.
(Nothing is even connected to the MidiMan Port B.)
I re-installed the Korg driver. Now I noticed that the LED light doesn't come on. Although after a few times and re-boots the LED light does come on. Still, there is no movement on the NK2.

Then this comes up. Screen shot 2012-05-01 at 1.43.34 PM.png

Why is this happening?

My Korg NanoKontrol2 Prefs show it as thus: Screen shot 2012-05-03 at 5.46.29 PM.png

Tonight when I started up, there is no LED light on.

Device: SLIDER?KNOB nanoKONTROL2 (is ghosted out)

Screen shot 2012-05-05 at 12.49.17 AM.png

Here is my Audio Midi Mac (Setup)...

Screen shot 2012-05-05 at 12.52.51 AM.jpg

Should the NonoKontrol2 Icon be ghosted out? as well as some ghosted out spaces in the "Properties" area.

My DX7 the Modulation and Pitch wheels assigned are fine and the On/Off button is also fine. (DX7)

Did something short out in the wiring? Any ideas? Please Help!


Peter Ostry

Staff member
1. Your nanoKONTROL icon in the Audio/MIDI Setup should not be dimmed. The pale icon tells you that your Mac doesn't see this device. You may have trouble with USB (hubs?).

2. I'm not sure if this is related to your problem, but have you switched the controller to MIDI mode? So far I know the nanoKONTROL 2 works with the Mackie protocol by default.



I had to put in the Korg NanoKontrol2 into the shop. It's still under warranty.
I tried everything. The LED light would sometimes come on...sometimes not...plug the USB cable and un-plug and re-plug and sometimes it came on...but still nothing could be assigned. Once in a while my 8th slider (Master) could/would control my 1st slider (vol)... but wasn't assigned to that one etc...so I put it in the shop. thanks


I'm sorry that I don't have the answers as I also having the same problem of nanokontrol2 is not recognized by Logic.

My current setup is: OS 10.8.2, Logic 9.1.8, nanokontrol2 (latest driver and firmware)

I was using nanokontrol2 with Logic 9 (i forgot on what version I was but def the latest) on 10.6 before and it was so easy to setup. Logic will read nanokontrol as soon as the driver installed.
Then due to some unfortunate issues, my OS got upgraded to 10.8 and Logic to 9.1.8. So I went the same process, got the latest driver and install it. The problem is when I open control surface preferences in Logic>Setup, I don't see nanokontrol2 anywhere
I have tried to scan it and it just didn't show up. I'm still trying to get it connected with Controller Assignments>Learn Mode but no luck so far. Even it I can work it out is there another easier way?

What should I do to make Logic recognizing nanokontrol2?

Any ideas/thoughts will be very much appreciated and I hope whatever shared here could be some help for you too xrc


NanoKontrol II Not working

Well the same thing happened to me. And I sent it back into the shop. They said it was the cable. I thought that wasn't the problem though. But, it works fine now....So, maybe you should buy a new cable. If not, I'm sorry...I'm not an expert...My best


I'm not so sure that the USB cable is the problem in my case, Logic 9.1.8 is simply not having korg nanokontrol2 in its device list.
My efforts are not successful yet but I don't see any future success in setting up these two things. Thinking to drop nanokontrol2 from my setup. A pity :(

Russ FAR

I just ordered one of these things too. I guess I shouldn't get my hopes up. I should've just saved up for the BCF2000. The other poor mans control surface lol.......


I know this is an older thread, but, being a NanoKontrol user myself, I thought I'd mention to anyone else coming across this conversation to make sure, if you're not seeing your device in Logic, and you're on a Mac, to go to the Audio MIDI Setup control panel in System settings (of the Mac, not Logic) to confirm that your device/control surface is showing up there. If not, then you don't have to worry about Logic (yet), as the hardware itself is not being recognized by the MacOS. [Which likely means a cable/interface/controller-hardware issue, if everything else is setup correctly]


New Member
Hey guys.. After SOOOO much faffing around and searching the internet for a fix to this (including deleting the p-list files etc.) I was about ready to throw my NanoKontrol 2 out of the window as I was just trying to use it in CC mode to control dynamics and expression (CC1 and CC11) which shouldn't be complicated right? But because of the control surface Mackie protocol the NanoKontrol is greyed out in Logic's Control Surfaces meaning I couldn't even select it.. Even when starting up the NanoKontrol 2 in DAW mode (not as a control surface / script) I even tried using the Korg editor to write a custom script for Logic (and Live which I use as well and worked fine) mapping everything like transports etc. but leaving the faders available for mapping to be able to ride Midi CC parameters on Kontakt instruments as well as one for CC7 to control master volume.. Nothing was working so I have actually bought a Beringer X-Touch Compact yesterday and then, sod's law.. about an hour later worked out the fix for NanoKontrol! Typical...

Basically - you just need to go into Logic Prefs / Control Surfaces / MIDI Controllers / and deselect 'AUTO' for the NanoKontrol..

Boom - everything 'just works' - I think it's something to do with the way Logic uses the custom script it keeps defaulting to it but this worked for me and now I can ride the CCs to my heart's content!!

Probably will keep the X-Touch Copact though as it has 10mm motorised faders (fancy!!) that are touch sensitive so it auto selects tracks and stuff.. as well as apparently really easy to switch between Mackie mode (which apparently according to 'The Internet' works perfectly in Logic!) and CC mode so I'll have those big-ass sexy faders to nuance the hell out of the parameters and then flick back into DAW control mode.. Should be fun!

Anyway.. Just thought I'd share as this was SO annoying for ages but turned out to be quite a quick fix!!