L9 Nudge broken

michaelo

LUG Emeritus
#1
Just noticed this behavior. When I try to nudge a region in L9 the left nudge button makes the selected region move to the right. The right button does nothing. This happens on all nudge settings.

Michael.
 

Markdvc

Administrator
Staff member
#2
Hi Michael

I had a quick look at this. Using the default L 9 KCs option + right cursor to nudge region/event position right by nudge value to the right, option + left cursor to nudge region/event position left by nudge value to the left seem to be both OK here on my Mac Pro and Mac Book Pro. Are these the nudge KCs you are referring to?

I also was able to nudge without any trouble with the two toolbar icons.

kind regards

Mark
 

michaelo

LUG Emeritus
#3
Hey Mark,
sorry I should have mentioned I only get this behavior using the toolbar icons. The KC's work fine but the toolbar left icon makes a region move right and the right nudge icon does nothing. Weird..
 

Markdvc

Administrator
Staff member
#4
That is indeed wierd. Is this happening with any and all regions you try to nudge? Is it reproducible in different logic projects?

FWIW, I have been able to use these buttons with audio and mid regions with a veriety of values set, from bar to sample. All of them work here fine.

You might want to try adding the nudge value icon to your toolbar if it isn't already there, and see if changes the nudge value might make a difference.

kind regards

Mark
 

Markdvc

Administrator
Staff member
#6
Yep, pretty strange Michael. Apart from the fact that the left button nudges to the right and the right button doesn't work, it seems that you set the nudge value to bars, but it is moving it in beats.

That is surely worth letting Apple know about, and perhaps we should move this to the Bug part of the forum?
 

Peter Ostry

Administrator
Staff member
#7
Can't reproduce this. My buttons and KeyCommands work as usual. Michael, maybe it helps when you remove the buttons from the toolbar and put them in again (not likely but who knows). What are your nudge KeyCommands doing?
 

michaelo

LUG Emeritus
#8
Ok I seem to have got it working using your method Peter. I opened the toolbar icons and dragged an additional set of nudge buttons onto the toolbar and they worked correctly. So there was this strange situation of two copies of the same buttons that in fact worked differently from each other.
This must be something to do with the preferences from L8 creating a problem. When I reset the toolbar to the default set of icons the problem has not reappeared.
Thanks for the help guys.

Regards
 

Markdvc

Administrator
Staff member
#9
I just opened a Logic 8 arrangement in Logic 9, and was able to reproduce this. I had previously been trying it in a fresh logic 9 arrangement. I moved the thread to the bug area.

kind regards

Mark
 
Top