Logic Pro 9 Latency issues (Logic Express 9)


I am a newbie here, and to the computer-based world of recording, and was wondering if anybody has any tips on correcting latency in Logic? When I play the instruments (particularly the pianos) within Logic, there is quite a bit of latency. I tried the low-latency mode button but that didn't seem to help at all. Thanks!

27" imac, 2.93 ghz i7, 8gb ram, 1tb, Duet, Motu Fastlane, SG Pro X 88-key piano/controller
What buffer size are you using?

(see FAQs if this doesn't make sense)

EDIT: It's in the Logic 8 FAQs, under the articles tab)
Upvote 0
Any and all tips would be appreciated! Particularly from any piano players out there. I am sure there is a way around this.

27" imac, 2.93 ghz i7, 8gb ram, 1tb, Duet, Motu Fastlane, SG Pro X 88-key piano/controller
Upvote 0
Everyone has a different way of doing things, but I never use software instruments when making a recording, even if I want to use them for their sample sounds and tweaking later on.

Instead, create and record-enable separate MIDI and audio tracks, then simultaneously record the audio from your SG Pro X while recording its MIDI out onto the MIDI track. I don't notice latency with a 128K buffer using software monitoring (it's measuring about 11ms), but you could just monitor the actual keyboard audio out if you experience more latency than me. That should give you near zero latency, but you should still check your routing with "software monitoring" enabled just to make sure your cabling is correct (then disable it when your record).

When you get the MIDI recorded, create a new software instrument track. Then copy your MIDI track onto the software instrument track. The audio track is useful as a guide when you start editing the MIDI, but you will end up muting it and just using the software instrument samples.
Upvote 0