Logic Pro X line up bar lines to midi and audio

edurbrow

Logician
I can't think of the right terminology to search this. I tried a couple of things to do with beat mapping. I want to line up the bar lines to the midi and audio without changing the sound and playback speed. In other words it seems to have been recorded with no regard to the tempo given.
Thanks in advance
 

Attachments

paulnajar

Logician
You’re on the right track with beat mapping. Effectively what that will give you is a variable logic tempo that follows the tempo (tempi) of your live performance.

You have to go through and drag a link from the actual beats in your live performance to the appropriate beat in Logic’s grid. Logic will insert the necessary tempo changes to keep your variable live tempo on it’s grid lines.

You don’t have to link every 16th or 1/4 beat of your performance. Depending on your performance and how tight to the gird you want it, you might only have to add a beat mapping link every bar or so. Hopefully that will help you. Also once the tempo map is made you can go and edit it so the changes in tempo are not so sudden. More like accellerando etc. That would make the click track more natural feeling if your goal was to add elements. All the Beat Mapping is in the Global Tracks area.

The only other option is to alter the actual timing of your performance to conform to Logics grid tempo. For Midi data that would be quantise and for audio data that would be quantise or hand edit in the Flex section of the software.

Logic recently added some tempo auto detection tools via the Follow and Adapt tempo functions but I just find them more of an annoyance than anything else. It’s probably just me not having learnt to use them properly.

Kind regards
 

edurbrow

Logician
You’re on the right track with beat mapping. ....
Thank you so much for your reply. It seems there is a way to do beat mapping with midi, but I'm having trouble with it. This looks like it should works it only ups the tempo by +12, but I get this message which does not appear in the screen shot:
Setting this beat would have caused the corresponding tempo value being too high. Try to delete bars.
 

Attachments

Last edited:

paulnajar

Logician
Definitely there is beat mapping with midi. Select the midi region before engaging beat mapping and off you go.


Looking at your screen shot you’re trying to beat map the clavinet track. Maybe try beat mapping the drum track underneath just so long as it’s in time. I don’t know why you’re getting those error messages.

As best I can tell you’re doing the right thing.
 

paulnajar

Logician
It’s been a while since I’ve had to use this feature but I do remember you have to be careful that you’re telling Logic the EXACT beat you intend your human performance to be mapped to. It’s always been predictable behaviour for me...
 
Top