Logic Pro 9 Lock Tempo


Hi- Someone recently asked about locking tempo points and was directed to the tempo operations window.

There used to be a nifty way to lock tempo to a measure and smpte point and then create a tempo change a beat before it. Logic would do the math and create whatever tempo was needed to make the next downbeat land on the desired smpte point. I cannot figure out to do this now. Even though it took a bit of time and having to write down information, it was a great feature. I hope it isn't gone.
Can someone tell me how this is achieved?

Here's the scenario in case I wasn't clear:

Starting tempo is 100bpm let's say you write a 12 bar cue. now at around measure 17 you want a new cue to start but, due to the picture, you want the downbeat at a precise smpte point.
You would open the tempo window and create 2 tempo changes. one at measure 17 and one at measure 16. you put in the time code you want the downbeat at for measure 17 and lock it. then a tempo is created for bar 16 that lines up the measure.

I tried to figure this out in the newer tempo operations window with no luck. PLease help if you know the solution.


Doug Zangar

This is still workable in Logic. I like to use markers, this is my method. You could do this other ways as well. I'd recommend having the key commands of Create Marker Without Rounding and Go To Next/Previous Marker.

1) Set your safety tempo at bar 16.

2) Set a marker at bar 16 and at the SMPTE time location of the desired bar 17

3) Open the tempo operations window, navigate with your above key commands to bar 16. The window will pick up the markers as your start and end points, no entry needed yet.

4) Settings.... Constant Tempo. Make sure BOTH padlocks are black, then in the right position box dbl click and type in 17, hit return. Make sure Continue with new tempo is checked and click Apply.

5) You can safely create a new tempo at bar 17 at this point.
Upvote 0


Thanks, Doug.

I will try this. I tried something like this but I couldn't lock the points. It was greyed out. But I'll try with your instructions.

Thanks again,
Upvote 0