Logic Pro 9 Logic 9.01 With Novation Remote SL Compact


New Member
Ive been using the Remote with Logic for over a year. I experienced this problem once before, but Im not sure how I corrected it. I was then using the remote without an issue for months. (Although I was really just using it as a midi control and bypassing the more detailed controls).

I have used anything from Automap 3.1 to 3.4. I upgraded to 3.4 yesterday, and the problem started again.

When I boot up Logic, the Remote recognizes it and I see midi coming in. However, when I start pressing keys on the Remote, its starts triggering various key commands in Logic - e.g. Punch In mode or Change Screenset. And it goes over and over, the screenset goes back and forth so its blinking non stop.

I went through all the trouble shooting that I could find. I dumped the Novation OS and used Automap to reset to defaults. It also re-uploaded all the templates. I tried both Template 38 and 39 (38 being Automap, 39 being dedicated to Logic)

I was able to shut of automap entirely, and also remove the remote from the control units. This allows me to play midi, but then I wont have any other controls.

I tried to set up the monitor in the environment as well, but Im not seeing any midi info coming into the monitor. But as I understand it - that is needed only to control the mixer from Logic 9.

Even with the Remote taken out of the environment, I still see the track listings appear from Logic on the Remote screen - but I cant control volumes.

Hopefully, this makes sense to someone! Im thinking I may be missing something small here (or so I hope!). Thanks

Given how many problems people seem to be having, Novation really needs to address this if they want to have people use their hardware as opposed to easier options.
Logic is capable of having any of the key commands assigned to MIDI notes. I thought it might be worth checking your key commands preferences to see if there are midi note assignments to it.

Side Story : I had a Novation Remote briefly, but found that it added to much effort to the workflow. It never made anything easier so I've put it in the closet. Plus three or four of the keys stopped functioning for no apparent cause and it was $250 to fix...
Upvote 0