Logic Pro 9 Logic 9.1.5 / Lion / Mackie Control Gremlin


New Member
Been using logic for years - including last 3 years with a Mackie Control Universal Controller, linked to an RME Fireface 800 audio / midi interface.
I've never had a single problem with the MCU.

Since moving to OSX Lion / Logic 9.1.5 I have a constant problem with the master fader on the MCU jumping to 0 ( and the same on screen ).

There are temporary work around such as delete the fader .cs file, or remove the controller from Logic / Preferences / Controllers etc. and re-scanning it but these are all just work-arounds.

The two things that get said to this question are generally a) do you have any automation - answer ( no ) not on the master fader and I have reproduced this problem with a blank empty project - just by pressing play.

b) do you lots of midi events going on - answer sometimes yes, sometimes no but it makes no difference.

c) are your midi cables ok - answer ( it works with my old mac ).

I have two youtube clips ( poor quality picture and terrible sound ) but it's an example at least of what's happening. You need to watch the entire clip to get the full picture.

Any help so very much appreciated - please be nice to me I'm having a really bad day.....



Apple have logged this as a potential bug. They have one or two other similar cases but it's not definite. I'd prefer it if it was something I'm doing.:brkwl:

Thanks Martin.
the same thing for me....
no problem with 'seeing' the hardware but faders go their own way
select, mute etc works fine
I removed the com.apple.logic files
normally everything comes together but in this case (after updating to Lion) no difference.

anybody ideas?
Upvote 0
Thanks for reply Jacques. I'm trying to build up a case with Apple over this. Can you tell me more details..what controller do you have? what audio interface?
Which version of Logic - (9.1.5 ) I guess if you're on Lion.
Upvote 0

I'm indeed using Lion, last update.
last update for logic pro as well
my audio converter is a motu 896 HD
and the controllers I use are Mackie control universal 2.1.2
and the Mackie control extender pro 3.0.0
both controllers are connected with the Motu micro lite midi converter
Hope you have enough information now.
thanks for your help and support so far
Upvote 0
I am pulling my hair out trying to come up with some workaround... Reset and rescan does not work for me... As soon as I turn on my Logic control my master fader goes all the way down, that's in any session I've tried... I really need to finish this session tonight and I would much prefer using my LC for mixing... Any ideas? Thanks for any input.



MP 2.66 (first gen)/16 GB RAM, 10.7.2, Apogee Ensemble, Unitor8/AMT8, all other software is up-to-date, all MIDI controllers except for LC are turned off.
Upvote 0
OK, so I've tried all possible workarounds -- switched to 64-bit version, deleted the master object from the environment, created a zillion empty tracks and so on and so forth... No go for me... Waiting for 10.7.3...


Upvote 0
I had this problem a few years ago. The controller can boot up in 2 different modes, mackie control or logic control. Try switching the mode it's in now.
Upvote 0
I had this problem a few years ago. The controller can boot up in 2 different modes, mackie control or logic control. Try switching the mode it's in now.

That was the first thing I did when I noticed the problem. Thanks anyway.

So 10.7.3 made no difference, neither did reverting to 10.6.8... This means it's not a system related bug. Now I will try to revert to previous versions of Logic and report back.


Upvote 0
Hey guys,

I know this is an old thread, but for those who still have MCUs and Logic Controls gathering dust, the issue with MCU/LC has been fixed in 10.8.4/LPX. My brand new rig is working like a dream with my good old LC as I type this message :) .

Best to all,

Upvote 0