Logic Pro 9 logic 9 on powermac g5 2ghz

ljpaddock

New Member
i read online that i could use logic 9 on my power pc which is running 10.5.8 osx. I splashed out on the software but had to use pacifist to install. now its installed i cant open it. i get a message saying its not supported on this architecture. can anyone help? its doing my head in.

cheers
Liam
 

Markdvc

Administrator
Staff member
Welcome to the LUG Liam.

While it was possible to install Logic 9.0, 9.0.1 and 9.0.2 on ppc macs, this was never officially supported by Apple, an intel Mac was (and still is) listed as a requirement.

Since Logic 9.1, Logic definitely will not run on PPC, it is coded for intel only.

kind regards

Mark
 

Markdvc

Administrator
Staff member
Feel free to let us know exactly which version you are using - there have been 6 releases of Logic 9:

9.0.0, 9.0.1, 9.0.2 - these could be installed on PPC Macs.

9.1.0, 9.1.1 and since last week 9.1.2 - these are Intel only.

Which do you have?

kind regards

Mark
 

Markdvc

Administrator
Staff member
Liam, try Command-clicking on the program icon in the applications folder to get information about it. But from reading your description it sounds very much like you have 9.1 or newer, which would indeed require an Intel Mac.

kind regards

Mark
 

ljpaddock

New Member
its version 9.1.1. damn. so if i got hold of an older version should i be ok with that? dont really have the money to upgrade my machine :-(
 
I bought the Logic Studio 9 v2.0 retail upgrade (from previous versions of Logic back to Gold or Platinum 5.5), and it did install on a G5 quad. Most of it, anyway, but not the applications related to Final Cut Pro. I am stuck at 9.0.2, though.
 
Top