Logic Pro 9 LOGIC ERROR: Not enough memory to create clipboard/undo

Perspex People

New Member

Afraid this will be a long post. The aim will be twofold:

1. To provide information on the above error and what I have tried in order to correct it.

2. Obviously to see if anyone has anything new to contribute as from what I see I am far from alone!

Before I start I have searched various forums for the above message with AND between words to narrow down otherwise thousands of results in order to make sure I have read the most appropriate posts and threads. Some posts across different sites presenting a variety of possible solutions.

Some background. Apple Mac Quad core, 5 GB RAM, Leopard 10.5.8, 32 Bit only.
System disk is 230GB with 135GB free and audio disk 750GB with 150GB free.
Last year I upgraded from logic 7 to vrs 9. Running now 9.1.3. Due to finishing most projects I have since later last year only been working on new ideas. I'm using only Logic and the Access Virus T1 desktop, so far with no real issues. All projects created from a logic template incorporating the set-up to facilitate the virus in the proper way. Also lots of the ideas all in one directory have been spawned from working on one project and then saving it as something else and so on... therefore if something has went wrong with one then that may be the case for many or even all projects and files.

The file in question is running 3-4 audio tracks, 16 virus tracks although not all have parts on them and around 10 logic instruments ranging from ultrabeat to exs24 piano and drum patches, nothing too intensive.

So for the first time (perhaps, I'm pretty sure) since installing Logic 9 last year I tried to make a quick arrangement, of what was all 4 bar loops, i:e lengthening the track beyond the initial 4 bar loops. I tried to do this by copying and pasting all the regions. To my utter shock and horror I discovered the error message above when I tried to paste much further than 100 bars of the song around 3-4 minutes of the arrangement. Since this I have received also the messages

"Not enough memory couldn't copy these events" AND
"Couldn't create regions" AND THEN AGAIN
"Not enough memory couldn't copy these events" THEN
"Out of memory couldn't insert or delete data".

So far I'm afarid to say that trying to find logic as to what message(s) appears first, whether I have to force quit on Logic and so on is difficult to say.


1.Saved the project as something else on desktop Same issue persists. And also checked all of the suggested fixes such as going to the project information and reorganising the memory and talking my undo steps right down to 1.

2.Tried to copy and paste in other project files possibly created from the same project, certainly from the same template, some of which have less instruments but always the 16 virus tracks, normally around 8-10 of them having parts and not all playing at the same time due to polyphony burglary! This creates the same issue. Although I note that files from the Logic 9 - Apple Pro Training Series book, seemed to copy and paste OK when I checked them but only briefly. But investigating them will not solve this issue....

3. I then tried again with back up files from the time machine. Same issue occurred.

4. Tried to create a new project from a blank template then import. The particular file I was working in causes Logic to crash, I see the spinning rainbow and have to force quit, or the import dialogue pretends to be looking for a file and it seems to take forever, then when I click on the screen or the import dialogue box the spinning rainbow appears and I have to force quit as this point.

I also tried to import some of the other files into a a blank template. I thought that perhaps narrowing it down to all files which would not import might help to narrow this down or provide some insight as to the real problem sadly that was another red herring. Some of the files which I imported with no trouble also had the copy and paste issue. (So another thing I had never cause to try not working consistently in Logic, The Import function however that will be for another post!)

5. I then thought that perhaps due to the addressing of virtual memory and the discussion regarding 32 bit version only being able to use 4GB that as my wastebasket was really full I would empty that as from what I've read the virtual memory uses the disk space. I therefore emptied the wastebasket and ran disk permission on the system drive and repaired the permissions also then verified the disk, all OK. I ran verify on the audio disk too. Again no issues with the disks however when I tried to copy and paste again I received the same frustrating error.

During this whole process I took some screenshots using the monitor and although the real and vm readings continued to grow whilst using logic at no point did the vm reading got to 4GB maximum was around 3.5. I did however note that the reading for instrument regions and undo steps was incredibly higher than I would have expected the latter turning around a memory reading of 11562322, is this normal in a relatively small project with less than 3 minutes of audio and instruments??

I think I btr wind it up there for now before putting everyone off reading my latest technical novel LOL however as there seems to be no solution to this across multiple forums on the web and also, and I hope everyone agrees with me here, not being able to copy and paste 3 minutes of work to create 6 minutes is totally insane and unacceptable. I can't believe for a minute that this exists in standard logic set-ups however with many users experiencing what some describe as memory hell there sure is no smoke without fire. I would therefore welcome a discussion on this and a quest to either find a solution or have apple take this issue seriously.

Thanks for reading and look forward to your thoughts, if only to keep me from going insane!!

Perspex People

New Member
Guys, found the solutions well in my case anyway. I had already noticed the region count in project info was way to high. being somwhat new to arrangeing in logic 9 I have been caught out, is how I would describe it. As soon as I flattened the take folders (as many of the midi regions had at least several takes) I was able to copy and paste throughout the song as desired. Something to watch although not sure if that would have been the cause for any of the earlier posts when some users were also having difficulty with this. Might be worth a try though...

I wonder if that had anything to do with the project not importing though which was the other issue I found. I will check and update in case anyone is interested.

Now to the music!