Logic hangs up


I just got my load of East West instruments.
I have two issues:

Logic hangs when I try to use the Gypsy violin to play a lane of solo violin in a project. If I leave it to just play a legato line its okay, but if I try articulation switching, it crashes the program.

I can't get my interface to work when an East West patch is loaded into Logic. They work fine through the interface when I test out sounds in East West in standalone mode, but not when its working as a plug-in through Logic.

Everything was going okay until I added the 3rd party.
I have a support email in to Soundsonline, but they may not have Logic answers.

Any suggestions?
Logic and EQ Gypsy Violin works fine here, ks no issue at all, with Kontact also running (this can sometimes cause issues)

What OS are you running? Have you tried to delete your gypsy prefs? it seems that the system you have is great, 8 gig of ram is fine. Are you in 64 bit or 32 bit mode in Logic?


Thank you George.
I am using Logic in 64bit, Snow Leopard 10.6.8.

I have not tried to delete the Gypsy preferences. I had no idea that would be useful. I'll have to read where they are deleted from. :rolleyes:

When this hang up occurred, I just had the Gypsy violin patch loaded, with a Bosendorfer piano from the Logic Library, and a bit of sound designer bussed to the piano.

I dropped a MOR P-bass and a Ludwig drum lit on another little piece I have been working on to test drive them, and they worked great. Key switching was perfect.

I certainly appreciate you taking the time to answer this cry for help.


Oh, by the way, the Interface USB, oddly, needs to be removed and re-inserted to gain access to it in Logic, or any program now. That was not necessary before.
Here's a thing to look at: Just use Logic's and your Mac's built in audio, completely remove the USB interface, see what happens. It could be a bad driver.

One other thing: go to your utilities folder, open the "Activity Monitor" then open the interface for it (yea, it doesn't open automatically, why, who the F knows) and keep an eye on a) the amount of ram you have left overall. If you are getting close to the amount of ram your system actually has due to the samples being loaded, well, that could be a big issue.

With a 64 bit version of Logic, your app doesn't have to worry about ram.

Are you have made sure you have the most recent version of Play right?


I down loaded Play last night.

I will check your suggestions ASAP.

Thank you, George.


I updated the firmware on the interface and it seems to be cooperating with the Play engine now. (Thank you, George.)
I will now tackle the hang up issues.
I was instructed by tech support to try setting the Play engine to Low.
I did that while Logic was up and guess what. Yep, Logic hung up.
Perhaps its axiomatic to do Play setting changes prior to Logic launch.

It is definitely the interaction between Play-Logic. Standalone Play instruments seem to work just fine. I could spend the next month auditioning them, with my wife calling from downstairs at midnight urging me to shut it down...:rolleyes:


I found another issue that was a conflict. My interface was set to 48 MHz and the Play plug-in was set to 44.1. With them both set to be 44.1 MHz, that seems to reduce the hang ups.

Now I just need to figure out the capacity Logic has to handle the humongus plug-ins like the Voices of Passion samples, the Violin with lots of keyswitches, and the Brass from QLSO. If anyone has an metric for that, I'd love to hear it.


Logic is still hanging up with violins

I have worked on a 19 track piece with several instruments from Goliath and QLSymphony Orchestra and everything went fine. I used big QLSO patch of French horns and cellos and added articulation with no problemo.
Then I decided to audition the solo violin and it hung up as I entered keyswitches below the track's melody.

Doesn't Logic like violins?