Logic Pro Logic Pro 10.7.1 Released

Markdvc

Administrator
Staff member
This would seem to be the first maintenance update after 10.7.0.

Logic Pro release notes

As usual, before updating, backup or make a copy of your current version of logic.
Logic 10.7.1 requires MacOS 10.16 Big Sur or newer.

Gruß

Mark
 
Top