Logic Pro 8 Logic Pro 8 Missing Various Multi Sets Korg M1

jraineey

Logician
Hello, Can someone please help with Installing a KORG M1instrument patches. I'm running on a MAC OS 10.6.8 Motu Traveler Audio Interface. I've updated from Logic Pro 8 to Logic X and want to set up Logic Pro 8 as an acoustic studio and add the KORG M1 as an external midi instrument.
 

CSeye

Logician
The attached is a Logic 9 file. You should be able to open it in L8. If not, I'll need to dig a bit deeper, or someone else can upload it for you.

Locate the M1 instrument in the Various Mulls file, copy it to your new template project Environment, and set it up.
 

Attachments

jraineey

Logician
Ok - I have gone through the steps I was able to open the logic various multi sets in Logic Pro 8. I’m not seeing the patches in the arrangement window.
I played the M1 to test if it was recording and it is but I do not here the recording.

Also when I suppress the keys on the M1 when I let up the key I hear the glockenspiel Sound but no instrument sound!

thank you for helping me figure this out!
 

Attachments

jraineey

Logician
I restarted my computer... And now the M1 is the master board and playing the logic sounds on the Piano Track but not the M1 sounds.

I still do not see the M1 patches or hear the sound on Track M1 1 in the pic attached.
Thank you so much for your help.

The Glockenspiel Sound is gone!
 

Attachments

CSeye

Logician
You're right about the missing patch names. I noticed the M1R (rack version?) does contain patch names. Are they the same as the M1? If so, you could use the M1R and cable it to your M1 keyboard.

Even though you currently don't see patch names, does changing patches in Logic change them on your M1?

Regarding not hearing the M1 sounds, is Local Control off on your keyboard? Typically, local control off prevents duplicate notes - once as you trigger your keyboard keys, and the second time as the MIDI notes are played back through Logic to your keyboard.

You'll need to have Local control off to record MIDI.
I've only used rack modules with a MIDI guitar controller so I may be missing some step here.
 
Last edited:

CSeye

Logician
Yes, remove the cable.

Where are the audio outs of the M1 routed to? M1 audio out to MOTU Traveler? Is the correct Traveler output selected as the input of the audio track in Logic? Do you see meter activity on the Traveler when recording MIDI in Logic?

Are both MIDI In and Out connected to your Traveler to send and receive MIDI?
 
Last edited:

jraineey

Logician
Hi! Finally success! Audio cables are connected to the Motu on channel 7-8.

Still no sound so I went back into the environment window and deleted the M1 Multi-Set and went to the options tab and imported the M1 Multi-Set. Previously I copied and pasted from the file you shared.

then I went back to the arrange window and removed the audio track and created a new audio track and assigned the inputs to 7-8 and Presto i hear the M1 Sounds! Yeah!

thank you so much! I’m ready now!
 

Attachments

Top