Logic Pro and Focusrite Saffire Pro 40 problem

nurserycryme

New Member
If anyone can help me it would be greatly appreciated. Just upgraded to the Saffire Pro 40 and I'm having a minor issue. Whenever I have anything plugged into one of the inputs on the Saffire, it comes through the monitors whether I have that channel record-enabled in Logic or not. In fact, even if I don't have Logic open it still comes through. I've tried using the Saffire MixControl to sort it out, but I'm not getting anywhere.
 

Janne

Logician
You need to mute that channel in the Saffire MixControl if You don't want to hear it directly.

The MixControl can be quite confusing, but it's fairly powerful when You know your way around it.
Think of it as controlling what You will hear through the Saffire different outputs. It doesn't do anything to the signal into Logic.

Good Luck!
 

nurserycryme

New Member
Thanks Janne. Yeah the problem righted itself after my power went out this morning and I've noticed that if I just don't open MixControl it works perfectly.
 

NeroMan2

New Member
If anyone can help me it would be greatly appreciated. Just upgraded to the Saffire Pro 40 and I'm having a minor issue. Whenever I have anything plugged into one of the inputs on the Saffire, it comes through the monitors whether I have that channel record-enabled in Logic or not. In fact, even if I don't have Logic open it still comes through. I've tried using the Saffire MixControl to sort it out, but I'm not getting anywhere.

I'm wondering how you like the Focusrite PRO 40? I just odered one myself and will be using over ADAT with my MOTU 8pre.
 
Top