Logic Pro 9 logic pro app store

daveyboy

Logician
I haven't but can tell you you'll need to be running Mac OSX.6.8 or above (Lion) as the newer versions of Logic won't work on the older operating systems. Other than that you shouldn't have any problems. I've bought a few things from the app store without incident. Go for it!


Sent from my iPad using Tapatalk
 
Top