Logic Pro 8 logic randomly freezes when loading a file


hey there, having a problem and need some quick help.

so stating yesterday, every time i load a particular mix i'm working on for a client, logic freezes at exactly the same moment--looking for an exs sample from the factory preset's grand piano. The program freezes, i have to force quit, and i cannot access the file.

problem is, the client is coming to listen to it....TOMORROW! :brkwl: Of course this would happen. gotta love murphy's law.

I have had this problem before in the past, and usually running the disk utility program and verifying my hard drives solves the problem. Not so this time around.

The other quick fix i've done in the past when this problem rears its head is to open the troubled file on a different computer and delete the exs instrument that's tripping up logic. But here's the kicker--this particular mix, the one that the client is coming over to inspect tomorrow, also freezes on all of my other machines! THIS HAS NEVER HAPPENED BEFORE AND I'M TEMPTED TO FLAIL MY ARMS ABOUT AND MAKE RANDOM NOISES OF PAIN AND FRUSTRATION! :angryfire:

Any of this ever happen to any of you guys? know a solution? might you know why this even frigging happens in the first place?

inquiring minds want to know!
I have had similar experiences with a Logic song ( I think it was using Logic 7) playing back and each time I played it, at the same point in the song, a kernel panic occurred. A PMU reset solved this. It involved Sony Oxford Plugins running on a powercore FW, it seemed that installing part of the Final Cut Studio package required a PMU reset after install to prevent this happening. It took me weeks to find the cause, the solution, in contrast, was so simple!

But that doesn't have to be in any way relevant for your issue. In order to get qualified help, you really should provide us with some system details.

kind regards

Upvote 0
more details

Let me tell you what my set up is.

I run logic 8 on a quad core intel mac--2.93 ghz of processing, 8 gigs of ram, os 10.5.8. I monitor through a hedd 192 which is connected via a lynx aes card. i also run an rme adi 2 out of this card for 2 channels of additional conversion (for outboard gear).

Come to think of it...this problem occurred when i hooked up my rme adi 2 and got it working a couple days ago...

to be clear, the problems i'm experiencing happen when logic first loads up the particular session, right when the exs instruments are loading.

i wish i understood how you're sony oxford (sonox?) plugin helped. perhaps you can explain it to me in more layman's terms--for instance, what do you mean by a "kernel panic"...and sorry if this is a stupid question :redface: but how does resetting the pmu help? just did a quick google on the subject, and found myself even more confused...

so there's my system setup. keeping in mind that i'm not as up on my computer lingo as i'd like to me, any ideas would could be causing the crash?
Upvote 0
I recently had this happen and I feel your pain for what it's worth. However in my case it was merely a Urie Click track sound that I have been using for maybe 12 years? In any case I loaded the file with audio off (there is a key command to do this or at least there used to be in the old days) saved the session without the click track loaded, and then it loaded with audio on. (I had another click track exs program that used the same sample and was fine). I deleted the exs program in question. maybe you can find an alternate piano sound or copy the exs program with another name...? gets dodgy...
Upvote 0
worth a shot

can you tell me the key command for starting up with the audio off?

the funny thing is, i'm not even using the piano that's freezing my session--logic instantiated this instrument when i imported a midi file and i guess i forgot to delete it!
Upvote 0
I guess it is control. this works in 8 not sure about 9. From the 8 manual:

Modifier key(s) Description Purpose
Control Start without Audio This can be helpful to rule out issues with a specific Core Audio driver. In some cases, Logic may stop responding or quit unexpectedly while initializing the Core Audio driver. In these cases, start Logic Pro or Logic Express without Audio. If needed, turn on Built-In Audio for the troubleshooting.
Shift-Control AU-Safe Mode This will only load Audio Units that have passed the Audio Units Validation Tool which is automatically launched on the very first startup of Logic. If you have enabled Audio Units that did not pass this test, you may experience unexpected quitting or misbehavior. With this option, you may revert Logic Pro or Logic Express to a stable state.

Option Start without Autoload/Template/LastRecent This will start Logic Pro or Logic Express without loading a Template, Autoload, or last-opened song. This can be useful for troubleshooting any kind of issue since it excludes the possibility that an issue is specific to or caused by the currently loaded song. Choosing File > New with the Option Key held down will load an empty default song for troubleshooting.
Upvote 0
Ok - sorry - cant you load either an empty song, or does logic ask you what to do when you load? Somehow you need to open a fresh song, prefs, audio, deselect whatever you use and click apply. You should be then 'turned off' and can proceed. Other solutions involve loading the song in L8, get into a fresh song and 'import' the problem tracks.
Why in the heck they disabled the control-key turn off function in 9 is just irritating.
Upvote 0
unfortunately, i wasn't able to make it work. though thanks for all of your posts on this! i tried what you said, opening up a fresh song, changing preferences around, but i couldnt figure out how to disable the exs instrument, and as such, couldnt open the tune.

i called apple for help. Guess what? They're not doing logic 8 tech support anymore for free. They wanted to charge me a one time consolation fee of 200 dollars. That kind of bs makes me want to quit using logic, but i like the program too much.

ended up redoing the track from scratch. everything turned out ok with the client. Still, it was a weird little fiasco there for a second...i'm sure it'll happen again...
Upvote 0
What a drag! However in the future once a song is loaded with no audio engine running, all you do is click on the offending exs24 inst. reset it to empty (no exs24 at all)
best - sorry I couldn't help you...
Upvote 0