Logic Pro X Logic X 10.2 Won't Load OS Catalina

Ectoflanger

Logician
Okay, an Apple Tech sent me here after we tried the usual fixes e.g. deleting plug-ins from the Components folder-

The problem occurred after I updated to OS Catalina on my late-2013 iMac from High Sierra (can't go back via Time Machine), Logic X will not open, but occasionally.

I had Novation's Automap app for my SL25 MKII which was disabled along with its uninstaller. Despite manually deleting all of the files listed in the locations by the Novation website, Logic continues to scan 43 files plugin files associated with Automap. They're even listed in the plugin manager.

So Logic scans the files then it shows the loading bars for my last project opened, but it only pops up on rare occasions.

Even when I deleted all third party plugins, I get the same result.

I also tried changing my Audio device settings-

The PLIST file does not exist on my computer, and when I do a Finder search for "automap", nothing appears but the PDF for the User's Manual.

Does anyone know if there are hidden FILES that I need to delete, and if so, how do I make them visible to delete?

I did send an email to Novation tech support addressing this issue this morning- waiting for a reply.

If this tells you anything, GarageBand was doing the same thing until I was luckily able to download an earlier version from the App Store, a luxury not afforded for Logic X.

Does anyone have additional suggestions?
 

Markdvc

Administrator
Staff member
Why 10.2, that is pretty old. Why not not update logic to the most recent version that will run on your Mac?
 
Upvote 0

Ectoflanger

Logician
I just did, but only because I saw how to do it via a 3 minute YouTube vid, Previously when I clicked on the Updates tab I got "No Updates" and an empty box, I still do and when I click Logic Pro X in the Apps section, I get an advisory that it is not compatible with my current operating system.

In the YouTube the person showed that if you click your user icon on the bottom left of the App Store, it wil give a list of all your apps that can be downloaded as updates when you click on the download symbol.


I did so, and now I have Logic X 10.6.3 which now works!

Now why couldn't Apple Techs tell me that? Honestly I was considering buying a new iMac to circumvent the issue-- perhaps that might have something to do with it?
 
Upvote 0
Top