Logic Pro X Logic X and Mavericks

Colin Shapiro

Logician
Well, Apple just announced that Mavericks (OS 10.9) is available today...for free!

Which brave users will be first to test out Logic X?
 

Colin Shapiro

Logician
For the record:
I cloned my boot drive and installed Mavericks just to do some testing.

Logic 10.0.4 seems to work fine.
Logic 9.1.8 also worked fine.
Logic 7.2.1 even opened and worked perfectly - great for opening old projects.

I didn't do extensive testing though....
 
Upvote 0

HKC

Logician
His problem is massive. Play behaves really strange. He uses a lot of RAM, I think he has 24GBs installed and uses most of it. Maybe it's the new compression of oldest-in-RAM-feature then.
If it is, it's bad news for everybody who works with big orchestral stuff. This particular guy has all 3 Hollywood packages and Vienna Dimension Brass along with EW Symphonic Orch so it's the really heavy stuff. It worked in Mountain Lion and I have already told him he's an idiot to upgrade so soon :)
 
Upvote 0

Multispace

Logician
His problem is massive. Play behaves really strange. He uses a lot of RAM, I think he has 24GBs installed and uses most of it. Maybe it's the new compression of oldest-in-RAM-feature then.
If it is, it's bad news for everybody who works with big orchestral stuff. This particular guy has all 3 Hollywood packages and Vienna Dimension Brass along with EW Symphonic Orch so it's the really heavy stuff. It worked in Mountain Lion and I have already told him he's an idiot to upgrade so soon :)

Maybe it's the App Nap feature that needs to be disabled for Logic X?
 
Upvote 0

Multispace

Logician
For the record:
I cloned my boot drive and installed Mavericks just to do some testing.

Logic 10.0.4 seems to work fine.
Logic 9.1.8 also worked fine.
Logic 7.2.1 even opened and worked perfectly - great for opening old projects.

I didn't do extensive testing though....

Did you try to run a 32-bit plug-in in Logic 9.1.8? I'm wondering if the 32 bit AU bridge is stable under 10.9 (at least not more unstable than before ;-))
 
Upvote 0

Colin Shapiro

Logician
Did you try to run a 32-bit plug-in in Logic 9.1.8? I'm wondering if the 32 bit AU bridge is stable under 10.9 (at least not more unstable than before ;-))
Not yet - just did some very simple testing i.e. opening and playing a few projects.
 
Upvote 0

Colin Shapiro

Logician
Okay - I just checked Logic 9.1.8 running in 32-bit mode, in Mavericks.

32-bit plug-ins seem to work just fine. I opened and tested a few instruments and effects and they were all fine. Sorry - can't report about using the bridge - I never used it before.
 
Upvote 0

Multispace

Logician
Okay - I just checked Logic 9.1.8 running in 32-bit mode, in Mavericks.

32-bit plug-ins seem to work just fine. I opened and tested a few instruments and effects and they were all fine. Sorry - can't report about using the bridge - I never used it before.

The 32 bit AU bridge automatically opens when you open 32 bit plug-ins when Logic 9 in running in 64 bit mode, which you can set via Get Info in the Finder (when Logic Pro 9 is selected).

:)
 
Upvote 0

Colin Shapiro

Logician
The 32 bit AU bridge automatically opens when you open 32 bit plug-ins when Logic 9 in running in 64 bit mode, which you can set via Get Info in the Finder (when Logic Pro 9 is selected).
I know, but I can't test that right now...
 
Upvote 0

campbell2002

Logician
I shouldn't have done it

Everything from my East West composers collection says it isn't licensed with ilok. And when I try to license again, it says the number is already in use. From one of the posts above it looks like even after I get the stuff licensed again I'll have troubles with the play engine deally.

Don't do it if you use East West stuff.
 
Upvote 0

HKC

Logician
Multispace wrote:
Maybe it's the App Nap feature that needs to be disabled for Logic X?

And how do I disable that .....
 
Upvote 0

Markdvc

Administrator
Staff member
And how do I disable that .....

Select Logic Pro X in the applications order in the finder and press Comm + I. Then simply uncheck the App Nap feature which you will see in the Info window. This is a new feature in Mavericks.

kind regards

Mark
 
Upvote 0

HKC

Logician
ILok works fine here. I have just spend 12 hours with a client and had no new problems at all.
As for the App Nap it's a matter of checking it if you don't want it so I suppose that's what I should tell my friend with huge Play problems to do....or what

All the best
Henrik
 
Upvote 0
Top