Logic Pro 9 Low Memory Problem

Colin Shapiro

Logician
Some info that may help

I have been working on a movie soundtrack and kept getting this memory low alert, and then the message "Logic is about to die and there's nothing you can do about it" or something like that.

I remembered this:
Go to the main [Options] menu and select [Project Information]
Click the button that says [Reorganize Memory]

That one kept me going for a whole lot longer before the death message.

Then I remembered this one:
Open an instance of EXS24 (if one is not yet open)
Click on the [Options] button top right on EXS24
Go down the menu and select [Virtual Memory]

Make sure [Active] is checked, then look below.
It says [External Memory Area] which has 3 options:
- Off, use only internal application memory
- On, optimized for more EXS instances
- On, optimized for more AU SI instances

The manual does not seem to discuss this in detail.
I had the option for more EXS instances checked, but I wasn't using that many EXS instances (only 3). However, I had 2 full Omnispheres, one RMX, three Vienna instances plus several EQ's, compressors, reverbs etc.

I changed to the 3rd option which I assume means Audio Unit Software Instrument instances. Since doing this, I haven't had a suicide note from Logic at all.

Try it - maybe it will help.....

Regards - Colin
 

afavreau

Logician
OK! Great! I did the Reorganize Memory

But my "External Memory Area" in EXS is greyed out. Have any idea why?

Andre
 

Markdvc

Administrator
Staff member
my "External Memory Area" in EXS is greyed out. Have any idea why?
Looking at the details you gave about your Mac here at the start of this thread, my guess would be that you don't have enough RAM. In order for the EXS virtual memory setting to work effectively, you need to have at least 5 GB installed. FAQ 16 links to an Apple KB document which describes this in more detail.

Can you add more RAM to your Mac Book Pro? The most recent models can have up to 8 GB.

kind regards

Mark
 
Last edited by a moderator:

afavreau

Logician
No I can't. I maxed out the Ram at 4GB!

This is a MacBook Pro that came out in 2008 and it can't use the Drum Replacement/Doubling feature because it has 35 tracks only (no Plug-ins)?

I'm in total disbelief! It doesn't make sense to me!

Thanks for your help

Andre
 

Howard W

Logician
on a G5, I'm not surprised. ; )

bd
It's not a processor problem, it's the low memory warning from using "Flex Time" on a fairly long audio track. True, I only have 4GB in the G5 but the same project in Logic 8 uses only a small amount of RAM. I'm convinced Flex Time is the culprit here.

Howard
 

Howard W

Logician
No I can't. I maxed out the Ram at 4GB!

This is a MacBook Pro that came out in 2008 and it can't use the Drum Replacement/Doubling feature because it has 35 tracks only (no Plug-ins)?

I'm in total disbelief! It doesn't make sense to me!

Thanks for your help

Andre
Andre, Flex Time & Drum replacement/doubling seem to be a very RAM intensive operations which proably mean the whole audio clip is loaded into RAM, perhaps twice, one to serve as an undo/compare. I think this is part of Logic's old architecture.

Logic has always needed to load audio into a designated area of RAM to be edited, altered...etc.

Howard
 

afavreau

Logician
Thanks Howard. What you say makes sense cause I have 10 Flex tracks.

I found a way though for rum replacement. I created a new session (save as) and deleted everything in the song except the drums for replacement. From there, I wll import back into the MIDI files and assign them to Superior Drummer.

Thanks
 

Colin Shapiro

Logician
It's not a processor problem, it's the low memory warning from using "Flex Time" on a fairly long audio track. True, I only have 4GB in the G5 but the same project in Logic 8 uses only a small amount of RAM. I'm convinced Flex Time is the culprit here.
Interesting...thanks for that heads-up Howard.
I also have a long Flex Time track in my project.

Changing the EXS24 prefs has fixed it for me though. I have 12GB of RAM in a Mac Pro so I assume that the RAM management has now improved in my situation.

It's good to consider all the culprits though!
 

afavreau

Logician
So basically, Time Flex is a feature that will go well with Snow Leopard, 64bit, and the new available amount of RAM in macs?
 

Howard W

Logician
Interesting...thanks for that heads-up Howard.
I also have a long Flex Time track in my project.

Changing the EXS24 prefs has fixed it for me though. I have 12GB of RAM in a Mac Pro so I assume that the RAM management has now improved in my situation.

It's good to consider all the culprits though!
Right... Since Logic is still running under the 4GB limitation, anything that uses RAM in that memory space is poses a problem if you're running low. I'm guessing you activated the EXS24 virtual memory option that allows running EXS24 in it's own memory space outside of Logic's 4GB limit.

As far as I know, at this time Snow Leopard shows no improvement in memory management running Logic.

Howard
 
I noticed that you don't mention your OS... 10.6 maybe? I know from doing tech work here in the LA area that every client who I have that runs 10.6 sees this error... I'm running 10.5.8 and haven't seen it once since I reverted to 10.5 from 10.6.

George Leger III
 

bobdemaa

Logician
Seems odd to me, and maybe it isn't a Logic problem. When you get that error, try opening up other applications to use up the Free RAM and see what happens. Are you experiencing any random quitting?
 

bobdemaa

Logician
That's a big problem for 10.6. Hope it gets addressed soon. I've been building a 10.6 system on the side and haven't really tested it yet. I'mm sticking with 10.5.8 until the coast is clear.
 

afavreau

Logician
I have X.5.8

Here's an interesting test. I captured my Activity Monitor screen to see how much Logic uses Ram in various situations. I'm very curious to see what you guys think. Is Flex taking much RAM, the Audio, Logic or the system itself?


1-logic_closed: Logic and softwares are all closed (except Activity Monitor and RME FF800 mixer/settings).

http://idisk.mac.com/favreau/Public/logic_closed.jpg


2-empty_project: This is when an empty Logic project is open. There are no plug-ins and no audio files. Just an empty project.

http://idisk.mac.com/favreau/Public/empty_project.jpg


3-no_flex: A project with 24 audio tracks only, no Flex tracks and no plug-ins.

http://idisk.mac.com/favreau/Public/no_flex.jpg


4-with_flex: Same Project as no_flex, but with 11 more audio flex tracks (8 drum and 3 vocal tracks) for a total of 35 tracks. This is the project that didn't allow me to use the "Drum Replacement/Doubling" feature because of Low Memory.

http://idisk.mac.com/favreau/Public/with_flex.jpg


For some reason, Activity monitor shows me more RAM being used when I have an empty project open than when i gave a big project open. I don't understand why.

I also always have that Kernel_task going on that bugs me a bit.


Andre
MacBook Pro, 2.5Ghz (early 2008), 4GB Ram, Mac Os X.5.8, 7200rpm internal HD, FW800 external 7200rpm HD, RME FireFace 800.
 

bobdemaa

Logician
Kernal Task is part of the system, it's not a problem here as I can see.

Audio Tracks in the system aren't going to be using more RAM. RAM usage will fluctuate a little, but really Free Ram will start to disappear as you start instancing and using Sample Based instruments, not audio tracks necessarily.

I use a Macbook Pro, 10.5.8, Logic 9, and I've never seen that message. large sessions, with Sampler instruments and Flex.

What is your Hardware Buffer set to in Logics audio Preferences? Just out of curiosity. If it happens to be really low, set it to 1024 and see if anything changes.

Also, is your FireFace Driver up to date?

bd

bd
 

afavreau

Logician
Buffer Size is normally set to 1024

I updated the latest driver recently because the former one was the cause of some Kernel Panics. So far, so good with the new one released on October 15th.

Andre
 

bobdemaa

Logician
Good to know regarding the FF driver.

I did a little bit of looking into it. See if any of these Copied and pasted suggestions I found help.

1) I found a post saying that they deleted all the markers out of the session and they stopped getting errors.

2) Reorganize Logic's internal memory. If you bring forward the Project Information window (Options > Project Information) you will see a button in the bottom left corner named "Reorganize Memory." This will optimize the amount of memory that your song requires, and may take care of this issue.

3) Try deleting your undo list. Edit Menu - Delete undo History

In the session with the Audio Tracks that is giving the Low Memory error, what Plug-ins are you using?
 

Colin Shapiro

Logician
I noticed that you don't mention your OS... 10.6 maybe? I know from doing tech work here in the LA area that every client who I have that runs 10.6 sees this error... I'm running 10.5.8 and haven't seen it once since I reverted to 10.5 from 10.6. George Leger III
I'm still using 10.5.8 and getting these suicide alerts. Logic quit on me twice yesterday.......at least it first saves the project. :(
 

afavreau

Logician
Thanks man,

Yeah, I allready reorganized the memory and deleted the undo once. I'll do it again. I'll also try deleting my few markers, but of course, this will modify the drums.

At first, my project had about 15 plug-ins, 25 flex tracks + 10 normal audio tracks. So Logic would just quit because of memory, so I then reduced and bounced everything in place to 23 normal audio tracks + 12 Flex tracks for a total of 35 with NO PLUG-INS.

Everything ran smoothly, but I couldn't use the Drum Replacement/Doubling feature because of low memory again. So I just exported my 8 track drums to another project for Drum replacement.

I'm looking into Activity Monitor now to reduce all the Ram I can, but there's a lot of mysteries going on there.

Does the audio bin take up ram?

Thanks
 

bobdemaa

Logician
The Audio bin shouldn't take up RAM in a way that would be causing that issue. I'm starting to wonder if you have Bad Ram...
 
Top