Logic Pro (X) LPX strange behaviour - bugs or features?


Hi there,
As a long time user of Logic (fourteen years professionally) I am having huge problems adapting to the latest version and can't work out if Logic has gone mental or the introduction of new features has 'stolen' some of the functions I took for granted.
Or if some of it's obviously buggy behaviour is caused by some of my plugins.
I'm using 32 Lives - which appears to run perfectly well and is a huge improvement on LP9 crappy 32 bit wrapper.
Also I am aware that Slate's VCC is still not quite happy and keeps causing Logic X to crash while opening songs utilising it - so this could also be part of at least one of the problems, but more of that later.
1. Can't edit Audio regions in Play Mode.
My first issue is when editing audio - specifically when trying to cut audio regions.
If it is actually in play mode Logic will not allow me to cut an audio region - either with the scissor tool or cut by locators/cut by playhead - when the region is highlighted.
Once I hit 'stop' it can be cut using any of those methods.
2. Audio Take Folders.
Another problem involving cutting audio files has reared it's ugly head when attempting to cut an Audio Take Folder.
If I cycle around a chorus, record a few BV takes - swipe to comp my fave parts and then decide the second half works best, when I attempt to cut the take, large parts of the wave form suddenly disappear from the take folder!
If I undo they come back, but I have never seen Logic behave like this before. So is this some behaviour based on a new feature meaning audio take folder work differently since LPX?
Or is it just a bug?
3. Missing Plugins
If I try to load up a plugin it sometimes shows up with a red exclamation mark proclaiming that the 'plugin can't be found' - particularly weird as this is for native Logic as well as third party plugins!
Again this problem is only present when in play mode.
As soon as I hit stop the red exclamation mark disappears from the plug and it functions perfectly.

Despite the fact that I have spent numerous days off trying to gen up on LPX - some great tuition vids on Youtube - I still do not feel confident to run a professional session using the latest version of this program.
Sad and frustrating as there are obviously some great new features here but for an old time daily user like myself they appear to have hidden many of what I consider to be part of the standard toolkit behind the kings new clothes...

This is actually the THIRD time I've posted here this week and though the help from fellow members here has been incredible and generous, if I hear the word 'workaround' again I think I'm going to scream.
Maybe Apple should put out a promo vid for Logic set to the Beach Boys 'I get around' with the lyric 'I Workaround'! :brkwl:
I think your key problem here is that you have an armed audio track. Logic X postpones loading plugins until the next time you hit stop, if you're recording or are "record ready" ie you have an armed audio track that could be dropped in to record (by hitting record whilst playing.) I have noticed and been annoyed by logic's region mangling behaviour whilst in this situation as well, the only solution I have come across is to disarm any audio tracks....
Upvote 0
But that would mean that Logic has gone backwards in it's capabilities!
I have been using Logic for fourteen years now and have had no such problems for as long as I can remember!
Quite often I'll record some guitar, then while it's still around my neck, and the track is still armed, chop up some of the audio for a particular section, then move onto the next, hit record, play until I'm happy, chop that and move on until I have parts I'm happy with for all sections.
I have NEVER had to disarm the track to edit the audio.
This is new behaviour in Logic X.
So I really can't accept that it's because the track is armed.
It just doesn't make sense.
All I can think is that it may be hidden in a preference or setting somewhere.
I used to know where all these lay and how to get to them to tweak my system to my needs but the new version has me foxed.
Also I find it impossible to tell, when zoomed out, which regions are muted or open.
Is there any way to customise the look of the Arrange page or has that been denied us too now?
Upvote 0
I think you're conflating two things, one which is intended (preventing plugins from instantiating whilst recording or record ready) I have to say this was always the best way of causing a crash in previous versions! And editing take folders whilst record ready which should work, and doesn't. I can't think of a reason for the random behaviour so I've chalked that up as a bug (if it was intended, the behaviour makes no sense, it should stop you, rather than f***ing up edits to teach you not to do it again!)
Upvote 0
Hi there,

Thanks for your kind reply.
And I do appreciate your suggestions.
However, if you read my post again, I'm afraid you'll find that it's your good self who is actually 'conflating' three things.
Which is why I listed each of my three problems as 1, 2 and 3.
They are all totally separate issues.

Just to clarify as I guess I maybe wasn't clear enough when first explaining -

My first problem is that when Logic has one Audio track armed and the song is playing (NOT recording Audio) it will not allow me to chop any of the Audio regions on the arrange page with scissors or any of my key commands despite the region being highlighted.

My second problem involved cutting Audio take folders.
This is NOT in record mode or even in play mode.
Sometimes they cut quite happily, other times all the audio in front section (earlier in the song) of the edit disappears from the take window and all audio behind(later) it seems to go out of time.
Undo fixes it.
Sometimes it works fine after several buggy edits and undos.
Totally confused about that this. And this is what made me wonder if looped Audio Take folders behaved differently than they used to.

The Third and final problem involves the loading of plugins and this problem is only in PLAY mode
ie when Logic is running - this even worked without hitch in Logic 4!
I'm fully aware that when recording it is not possible to load up new plugins and I was not attempting to do that.
Somehow Logic seems to lose it's way to the components folder, even for it's own Logic plugs (ie non third party) and stamps a red exclamation mark across the plugin slot.
As soon as you stop Logic playing it appears and works fine.
As I said earlier, Slate's VCC seems to crash some of my songs during startup so that could be the issue.
Or the fact that I'm using 32 Lives with some very 'antiquated' but loved plugs that
a I can't afford to replace with updates or
b Were Freeware and will probably never be ported to 64 bit.
Dunno, but it's weird, intermittent and extremely frustrating.
Maybe the new 10.0.07 may debug some of this.
Sadly I suspect not.
Also is just me or does the new way of colouring mutes sometimes make it impossible to tell which regions are muted or open when in a very complex arrangement?
Is there a way of changing the how the visuals behave or are we now stuck with a version that looks like it may have been colour coded by several blind Goths on acid? :eeek:
Upvote 0
Hmm, I haven't had a problem with 1 (Although it will randomly mangle edits on recording tracks) . 2 i've only had when record armed/recording. As to 3, I have noticed that it sometimes gives the warning icon temporarily when playing but will load the plug properly (this sounds like something plugin specific, possibly it takes longer for wrapped plugins to load..) for me, some plugs will take a few seconds with the warning icon before working

Sent from my iPhone using Tapatalk
Upvote 0
Ah, so it's not just me then!!

Praise the Lard for that - I thought I was losing my mind - again.

The missing plugs are often Logic's own - so shouldn't a wrapper issue there...

As you say, they appear quite happily when it stopped mode. They just sometimes don't like to load while playing.

Yeah, the mute graphic is a bit crap now in my opinion.
It's a pisser you can't tweak it all like you could in the past.

One final question while we're 'chatting'
Any way of making a full page mixer instead of a half arsed feature along the bottom of the arrange page?
I rather prefer a dedicated one like I used to use with my screen sets....
Upvote 0
I believe you can pull out a mixer window from the windows menu, although only one row, the other way is to make your own with the environment window

Sent from my iPhone using Tapatalk
Upvote 0