Magical 8Bit Plug In


New Member
Hey everyone

I've recently gotten hold of Logic Pro 9 since GarageBand had reached its limitations. I am running Logic Pro 9.1.7, on a mid 2011 iMac, with OSX Lion 10.7.3.

One plug in that I was intent on using (having relied on it heavily in GarageBand) was the Magical 8-Bit Plug-in by YMCK. However, I can't find it anywhere in Logic; I've checked the software instruments selection box, all the effects inserts... nothing. It's like Logic just doesn't like it!

I've tried opening Logic in both 32 bit and 64 bit, still no joy... It's odd because the plug-in actually runs fine in GarageBand :S

Hope you can help, thanks in advance!

-Sorry by the way, I know there are a fair few M8-B threads on here, but I've had a flick through regarding this problem and none of the threads seem to have the fix I need :(


New Member
That's the thing, it SHOULD see it as an instrument. But it doesn't come up in my drop-down list :/
Check and make sure it's enabled in Logic's AU manager. Under the Main Logic menu...

You could also make sure it's in your "components" folder in your main library/audio.components folder. You might have to use an app called "Lion Tweaks" to enable the Library folder to be seen... Mac OS 10.7 hides it.


New Member
Checked the AU manager.. lol it's not even on the list.

It IS in the components folder though, I put it there myself last night- and like I said, GarageBand seems to register it fine..

(And also- if you hold Option when you select Finder's 'Go' menu, the Library appears in the list :) That had me stumped for a bit lol)
Did you run Logic in 32 bit mode to make sure it got scanned properly? You must do this or Logic won't see it).

Other than that I's suggest you pull the copy in your components, get a new one off the net, install it, and run Logic in 32 bit mode. I tried it and everything worked first time.